aboutsummaryrefslogtreecommitdiffstats
path: root/net/nepenthes
diff options
context:
space:
mode:
Diffstat (limited to 'net/nepenthes')
-rw-r--r--net/nepenthes/Makefile8
-rw-r--r--net/nepenthes/files/prelude_modules_log-prelude_Makefile.in.patch11
2 files changed, 18 insertions, 1 deletions
diff --git a/net/nepenthes/Makefile b/net/nepenthes/Makefile
index 10cacd0f2759..decdc3339549 100644
--- a/net/nepenthes/Makefile
+++ b/net/nepenthes/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nepenthes
PORTVERSION= 0.1.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= nepenthes
@@ -20,6 +20,12 @@ LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl \
pcre.0:${PORTSDIR}/devel/pcre \
adns.1:${PORTSDIR}/dns/adns
+.if defined(WITH_PRELUDE)
+LIB_DEPENDS+= prelude.10:${PORTSDIR}/security/libprelude
+CONFIGURE_ARGS+= --enable-prelude
+EXTRA_PATCHES= ${FILESDIR}/prelude_modules_log-prelude_Makefile.in.patch
+.endif
+
USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/net/nepenthes/files/prelude_modules_log-prelude_Makefile.in.patch b/net/nepenthes/files/prelude_modules_log-prelude_Makefile.in.patch
new file mode 100644
index 000000000000..8a9878e29c0f
--- /dev/null
+++ b/net/nepenthes/files/prelude_modules_log-prelude_Makefile.in.patch
@@ -0,0 +1,11 @@
+--- modules/log-prelude/Makefile.in.orig Sun Apr 23 19:49:07 2006
++++ modules/log-prelude/Makefile.in Fri Oct 20 15:01:06 2006
+@@ -195,7 +195,7 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ AUTOMAKE_OPTIONS = foreign
+-AM_CPPFLAGS = -I/usr/include/libprelude -I$(top_srcdir)/nepenthes-core/include -I$(top_srcdir)/nepenthes-core/src -pipe -D _GNU_SOURCE
++AM_CPPFLAGS = -I/usr/local/include/libprelude -I$(top_srcdir)/nepenthes-core/include -I$(top_srcdir)/nepenthes-core/src -pipe -D _GNU_SOURCE
+ AM_CXXFLAGS = -Wall
+ AM_LDFLAGS =
+ pkglib_LTLIBRARIES = logprelude.la