aboutsummaryrefslogtreecommitdiffstats
path: root/net/ntp
diff options
context:
space:
mode:
Diffstat (limited to 'net/ntp')
-rw-r--r--net/ntp/Makefile5
-rw-r--r--net/ntp/files/patch-ntpd_ntp.c11
2 files changed, 15 insertions, 1 deletions
diff --git a/net/ntp/Makefile b/net/ntp/Makefile
index fe585dedb587..c2c32faf4829 100644
--- a/net/ntp/Makefile
+++ b/net/ntp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ntp
PORTVERSION= 4.2.8p13
-PORTREVISION= 2
+PORTREVISION= 4
CATEGORIES= net ipv6
MASTER_SITES= http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ \
http://archive.ntp.org/ntp4/ntp-4.2/ \
@@ -79,6 +79,9 @@ post-extract:
@${TOUCH} ${WRKSRC}/scripts/build/checkHtmlFileDates
@${CHMOD} +x ${WRKSRC}/scripts/build/checkHtmlFileDates
+post-configure:
+ @${ECHO_CMD} '#define HAVE_CLOSEFROM 1' >> ${WRKSRC}/config.h
+
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/conf/* ${STAGEDIR}${EXAMPLESDIR}
diff --git a/net/ntp/files/patch-ntpd_ntp.c b/net/ntp/files/patch-ntpd_ntp.c
new file mode 100644
index 000000000000..3f8187a072e4
--- /dev/null
+++ b/net/ntp/files/patch-ntpd_ntp.c
@@ -0,0 +1,11 @@
+--- ntpd/ntpd.c.orig 2019-02-20 09:21:44.000000000 -0800
++++ ntpd/ntpd.c 2019-09-20 12:11:54.469651000 -0700
+@@ -999,7 +999,7 @@
+ # if defined(HAVE_MLOCKALL)
+ # ifdef HAVE_SETRLIMIT
+ ntp_rlimit(RLIMIT_STACK, DFLT_RLIMIT_STACK * 4096, 4096, "4k");
+-# ifdef RLIMIT_MEMLOCK
++# if defined(RLIMIT_MEMLOCK) && defined(DFLT_RLIMIT_MEMLOCK) && DFLT_RLIMIT_MEMLOCK != -1
+ /*
+ * The default RLIMIT_MEMLOCK is very low on Linux systems.
+ * Unless we increase this limit malloc calls are likely to