aboutsummaryrefslogtreecommitdiffstats
path: root/net/portfwd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/portfwd/Makefile')
-rw-r--r--net/portfwd/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net/portfwd/Makefile b/net/portfwd/Makefile
index a78a4e8b8b3f..f095cfd5a252 100644
--- a/net/portfwd/Makefile
+++ b/net/portfwd/Makefile
@@ -23,6 +23,12 @@ USE_REINPLACE= yes
MAN5= portfwd.cfg.5
MAN8= portfwd.8
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if defined(NOPORTDOCS)
post-configure:
@${REINPLACE_CMD} -e "s|\(^install-data-am:\) install-docDATA|\1|g" \
@@ -36,4 +42,4 @@ post-install:
@${MKDIR} ${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/cfg/* ${EXAMPLESDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>