aboutsummaryrefslogtreecommitdiffstats
path: root/net/py-mp-random/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/py-mp-random/Makefile')
-rw-r--r--net/py-mp-random/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/net/py-mp-random/Makefile b/net/py-mp-random/Makefile
new file mode 100644
index 000000000000..a4bffd70ccd9
--- /dev/null
+++ b/net/py-mp-random/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: py-MirrorProjectRandomImageWidget
+# Date created: August 03, 2004
+# Whom: Aaron Straup Cope ascope@cpan.org
+#
+# $FreeBSD$
+#
+
+PORTNAME=mp-random
+PORTVERSION= 1.0
+CATEGORIES= net python
+MASTER_SITES= http://mirrorproject.com/widget/
+PKGNAMEPREFIX= py-
+DISTNAME= MirrorProjectRandomImageWidget-src-${PORTVERSION}
+
+MAINTAINER= randomimage-widget@mirrorproject.com
+COMMENT= Display random Mirror Project images on your desktop
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/wxPython/wxc.so:${PORTSDIR}/x11-toolkits/py-wxPython
+
+USE_PYTHON= yes
+USE_X_PREFIX= yes
+NO_BUILD= yes
+
+pre-install:
+ ${PRINTF} "#!${PYTHON_CMD}\n" > ${WRKSRC}/mp-random
+ ${CAT} ${WRKSRC}/MirrorProjectRandomImageWidget.py >> \
+ ${WRKSRC}/mp-random
+ ${CHMOD} 0755 ${WRKSRC}/mp-random
+
+do-install:
+ ${ECHO} "Installing ${PREFIX}/bin/mp-random"
+ ${CP} ${WRKSRC}/mp-random ${PREFIX}/bin/
+
+.include <bsd.port.mk>