aboutsummaryrefslogtreecommitdiffstats
path: root/net/recvnet/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/recvnet/Makefile')
-rw-r--r--net/recvnet/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net/recvnet/Makefile b/net/recvnet/Makefile
new file mode 100644
index 000000000000..3204d1bcd868
--- /dev/null
+++ b/net/recvnet/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: recvnet
+# Date created: 27 Sep 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= recvnet
+PORTVERSION= 0.0.1
+CATEGORIES= net
+MASTER_SITES= http://www.vanheusden.com/Linux/ \
+ http://critical.ch/distfiles/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Recvnet (inverse telnet) is a utility for debugging tcp connections
+
+CFLAGS+= -DVERSION=\"${PORTVERSION}\"
+LDFLAGS+= -lcurses
+
+PLIST_FILES= bin/recvnet
+
+do-build:
+ ${CC} ${CFLAGS} -c ${WRKSRC}/${PORTNAME}.c -o ${WRKSRC}/${PORTNAME}.o
+ ${CC} ${LDFLAGS} ${WRKSRC}/${PORTNAME}.o -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>