aboutsummaryrefslogtreecommitdiffstats
path: root/net/ruby-icmp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/ruby-icmp/Makefile')
-rw-r--r--net/ruby-icmp/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/net/ruby-icmp/Makefile b/net/ruby-icmp/Makefile
new file mode 100644
index 000000000000..b1c556e934d4
--- /dev/null
+++ b/net/ruby-icmp/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: ICMPModule for Ruby
+# Date created: 1 Nov 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= icmp
+PORTVERSION= 0.1.0
+CATEGORIES= net ruby
+MASTER_SITES= http://www.notwork.org/~gotoyuzo/ruby/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+EXAMPLES= ping.rb
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/icmp.rb ${RUBY_SITELIBDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/icmp
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/icmp/
+.endfor
+.endif
+
+.include <bsd.port.mk>