aboutsummaryrefslogtreecommitdiffstats
path: root/net/wol/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/wol/Makefile')
-rw-r--r--net/wol/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/net/wol/Makefile b/net/wol/Makefile
index 7c30845bc4de..5dfff03ea7a5 100644
--- a/net/wol/Makefile
+++ b/net/wol/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= wol
-PORTVERSION= 0.6.0
-PORTREVISION= 4
+PORTVERSION= 0.7.1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ahh
@@ -18,13 +17,22 @@ COMMENT= Tool to wake up Wake-On-LAN compliant computers
GNU_CONFIGURE= yes
USE_GETOPT_LONG= yes
-USE_GETTEXT= yes
-USE_ICONV= yes
+USE_GPG= yes
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB= NLS="@comment "
+.else
+USE_GETTEXT= yes
+USE_ICONV= yes
+PLIST_SUB= NLS=""
+.endif
+
+MAN1= wol.1
INFO= wol
DOCS= AUTHORS NEWS README TODO