aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/boinc-client/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net/boinc-client/Makefile b/net/boinc-client/Makefile
index cdc6d7bca044..6641b0377db2 100644
--- a/net/boinc-client/Makefile
+++ b/net/boinc-client/Makefile
@@ -32,6 +32,12 @@ BOINC_GROUP= nobody
BOINC_HOME= /var/db/boinc
BOINC_DATADIR= ${PREFIX}/boinc
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= Does not compile on 64-bit architectures
+.endif
+
post-patch:
${CHMOD} +x ${WRKDIR}/boinc_public/configure
@@ -94,4 +100,4 @@ post-install:
${TMPPLIST}
@${SETENV} ${SCRIPTS_ENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>