aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/kdenetwork4/Makefile1
-rw-r--r--net/kdenetwork4/distinfo4
-rw-r--r--net/kdenetwork4/files/patch-svn_1292762.diff65
3 files changed, 2 insertions, 68 deletions
diff --git a/net/kdenetwork4/Makefile b/net/kdenetwork4/Makefile
index 98f8f993e9a2..3880ae02c332 100644
--- a/net/kdenetwork4/Makefile
+++ b/net/kdenetwork4/Makefile
@@ -6,7 +6,6 @@
PORTNAME= kdenetwork
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 2
CATEGORIES= net kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
diff --git a/net/kdenetwork4/distinfo b/net/kdenetwork4/distinfo
index bc6297cdb0c3..bc64dcf5d2c3 100644
--- a/net/kdenetwork4/distinfo
+++ b/net/kdenetwork4/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/kdenetwork-4.8.3.tar.xz) = 9acf05bc77b3cc500b7364936882f5c5f07f3938f426ce262d4065de11cae380
-SIZE (KDE/kdenetwork-4.8.3.tar.xz) = 9267740
+SHA256 (KDE/kdenetwork-4.8.4.tar.xz) = 6c2d7dfc13523854619f764baede5bbadec19a7989bf8e958f6eab119fcf9e82
+SIZE (KDE/kdenetwork-4.8.4.tar.xz) = 9268552
diff --git a/net/kdenetwork4/files/patch-svn_1292762.diff b/net/kdenetwork4/files/patch-svn_1292762.diff
deleted file mode 100644
index 81071b21da48..000000000000
--- a/net/kdenetwork4/files/patch-svn_1292762.diff
+++ /dev/null
@@ -1,65 +0,0 @@
-Index: kopete/protocols/jabber/googletalk/libjingle/talk/base/socketaddress.cc
-===================================================================
---- kopete/protocols/jabber/googletalk/libjingle/talk/base/socketaddress.cc (revision 1292761)
-+++ kopete/protocols/jabber/googletalk/libjingle/talk/base/socketaddress.cc (revision 1292762)
-@@ -31,6 +31,7 @@
- #include <netinet/in.h>
- #include <arpa/inet.h>
- #include <netdb.h>
-+#include <unistd.h>
- #endif
-
- #include <cstring>
-Index: kopete/protocols/jabber/googletalk/libjingle/talk/base/ssladapter.cc
-===================================================================
---- kopete/protocols/jabber/googletalk/libjingle/talk/base/ssladapter.cc (revision 1292761)
-+++ kopete/protocols/jabber/googletalk/libjingle/talk/base/ssladapter.cc (revision 1292762)
-@@ -27,6 +27,12 @@
-
- #include "talk/base/ssladapter.h"
-
-+#ifdef POSIX
-+extern "C" {
-+#include <unistd.h>
-+}
-+#endif
-+
- #if !defined(SSL_USE_SCHANNEL) && !defined(SSL_USE_OPENSSL)
- #ifdef WIN32
- #define SSL_USE_SCHANNEL 1
-Index: kopete/protocols/jabber/googletalk/libjingle/talk/base/stringutils.h
-===================================================================
---- kopete/protocols/jabber/googletalk/libjingle/talk/base/stringutils.h (revision 1292761)
-+++ kopete/protocols/jabber/googletalk/libjingle/talk/base/stringutils.h (revision 1292762)
-@@ -198,15 +198,6 @@
- }
-
- template<class CTYPE>
--size_t sprintfn(CTYPE* buffer, size_t buflen, const CTYPE* format, ...) {
-- va_list args;
-- va_start(args, format);
-- size_t len = vsprintfn(buffer, buflen, format, args);
-- va_end(args);
-- return len;
--}
--
--template<class CTYPE>
- size_t vsprintfn(CTYPE* buffer, size_t buflen, const CTYPE* format,
- va_list args) {
- int len = vsnprintf(buffer, buflen, format, args);
-@@ -217,6 +208,15 @@
- return len;
- }
-
-+template<class CTYPE>
-+size_t sprintfn(CTYPE* buffer, size_t buflen, const CTYPE* format, ...) {
-+ va_list args;
-+ va_start(args, format);
-+ size_t len = vsprintfn(buffer, buflen, format, args);
-+ va_end(args);
-+ return len;
-+}
-+
- ///////////////////////////////////////////////////////////////////////////////
- // Allow safe comparing and copying ascii (not UTF-8) with both wide and
- // non-wide character strings.