aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/p5-Net-Patricia/Makefile5
-rw-r--r--net/p5-Net-Patricia/distinfo6
-rw-r--r--net/p5-Net-Patricia/files/patch-libpatricia-patricia.c10
3 files changed, 5 insertions, 16 deletions
diff --git a/net/p5-Net-Patricia/Makefile b/net/p5-Net-Patricia/Makefile
index 1e1de02ee35f..9bfe93f2deaa 100644
--- a/net/p5-Net-Patricia/Makefile
+++ b/net/p5-Net-Patricia/Makefile
@@ -6,19 +6,18 @@
#
PORTNAME= Net-Patricia
-PORTVERSION= 1.010
+PORTVERSION= 1.014
CATEGORIES= net perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
http://net.doit.wisc.edu/~plonka/Net-Patricia/
MASTER_SITE_SUBDIR= Net
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= clsung@FreeBSD.org
COMMENT= Perl module for fast IP address lookups
PERL_CONFIGURE= YES
MAN3= Net::Patricia.3
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
.include <bsd.port.mk>
diff --git a/net/p5-Net-Patricia/distinfo b/net/p5-Net-Patricia/distinfo
index 16320cfb5da0..26b763f305d3 100644
--- a/net/p5-Net-Patricia/distinfo
+++ b/net/p5-Net-Patricia/distinfo
@@ -1,3 +1,3 @@
-MD5 (Net-Patricia-1.010.tar.gz) = 19f0c6944769daba64694ee3c72cf286
-SHA256 (Net-Patricia-1.010.tar.gz) = ede01d28b04227378f4f434ce5a85987a101670fcfe942bb2e3f34806cedd7c7
-SIZE (Net-Patricia-1.010.tar.gz) = 23499
+MD5 (Net-Patricia-1.014.tar.gz) = 16ec73b5b514dbe4275e349fca236c49
+SHA256 (Net-Patricia-1.014.tar.gz) = 0e5e26aea2a693a51968c4f34e8e9c6a4a7b5a6f5897c88471059315f1691ae8
+SIZE (Net-Patricia-1.014.tar.gz) = 24539
diff --git a/net/p5-Net-Patricia/files/patch-libpatricia-patricia.c b/net/p5-Net-Patricia/files/patch-libpatricia-patricia.c
deleted file mode 100644
index 77abc561ae30..000000000000
--- a/net/p5-Net-Patricia/files/patch-libpatricia-patricia.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- libpatricia/patricia.c.orig Wed Nov 27 09:51:16 2002
-+++ libpatricia/patricia.c Wed Nov 27 09:52:14 2002
-@@ -24,6 +24,7 @@
- #include <stdio.h> /* sprintf, fprintf, stderr */
- #include <stdlib.h> /* free, atol, calloc */
- #include <string.h> /* memcpy, strchr, strlen */
-+#include <sys/types.h>
- #include <arpa/inet.h> /* for inet_addr */
-
- #include "patricia.h"