aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/scdp/Makefile23
-rw-r--r--net/scdp/distinfo1
-rw-r--r--net/scdp/pkg-comment1
-rw-r--r--net/scdp/pkg-descr8
-rw-r--r--net/scdp/pkg-plist1
6 files changed, 35 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index c1241d2e2661..bf7c43e21d70 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -368,6 +368,7 @@
SUBDIR += sambasentinel
SUBDIR += samplicator
SUBDIR += satellite
+ SUBDIR += scdp
SUBDIR += scotty
SUBDIR += scotty3
SUBDIR += sdl_net
diff --git a/net/scdp/Makefile b/net/scdp/Makefile
new file mode 100644
index 000000000000..f28fc685b464
--- /dev/null
+++ b/net/scdp/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: scdp
+# Date created: 14 September 2001
+# Whom: arved@arved.de
+#
+# $FreeBSD$
+
+PORTNAME= scdp
+PORTVERSION= 1.0.b
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= scdp
+
+MAINTAINER= freebsdports@arved.de
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+post-patch:
+ @${PERL} -pi -e 's,malloc.h,stdlib.h,' ${WRKSRC}/scdp.c
+
+.include <bsd.port.mk>
diff --git a/net/scdp/distinfo b/net/scdp/distinfo
new file mode 100644
index 000000000000..50e056b9eedd
--- /dev/null
+++ b/net/scdp/distinfo
@@ -0,0 +1 @@
+MD5 (scdp-1.0b.tar.gz) = 7eafaf5a422e37d04715613993ed5d95
diff --git a/net/scdp/pkg-comment b/net/scdp/pkg-comment
new file mode 100644
index 000000000000..ef8092ed3db8
--- /dev/null
+++ b/net/scdp/pkg-comment
@@ -0,0 +1 @@
+Tool that sends CDP (CISCO Discovery Protocol) Packets
diff --git a/net/scdp/pkg-descr b/net/scdp/pkg-descr
new file mode 100644
index 000000000000..925c2829891e
--- /dev/null
+++ b/net/scdp/pkg-descr
@@ -0,0 +1,8 @@
+This program sends CDP (Cisco Discovery Protocol) packets out on selected
+interfaces and tells the connected switch (Cisco only) where the host is
+connected.
+
+WWW: http://sourceforge.net/projects/scdp/
+
+-arved
+arved@arved.de
diff --git a/net/scdp/pkg-plist b/net/scdp/pkg-plist
new file mode 100644
index 000000000000..f49508fe28fb
--- /dev/null
+++ b/net/scdp/pkg-plist
@@ -0,0 +1 @@
+bin/scdp