aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/dhcpcd/Makefile2
-rw-r--r--net/dhcpcd/distinfo4
-rw-r--r--net/dhcpcd/files/dhcpcd.in24
-rw-r--r--net/dhcpcd/files/patch-dhcpcd.conf13
-rw-r--r--net/dhcpcd/pkg-message4
5 files changed, 20 insertions, 27 deletions
diff --git a/net/dhcpcd/Makefile b/net/dhcpcd/Makefile
index 8f56528bbd46..de8c410a69f2 100644
--- a/net/dhcpcd/Makefile
+++ b/net/dhcpcd/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= dhcpcd
-PORTVERSION= 6.10.1
+PORTVERSION= 6.10.2
CATEGORIES= net
MASTER_SITES= http://roy.marples.name/downloads/dhcpcd/ \
http://roy.aydogan.net/dhcpcd/ \
diff --git a/net/dhcpcd/distinfo b/net/dhcpcd/distinfo
index 30a3e1f84ad6..011a94d5c5a7 100644
--- a/net/dhcpcd/distinfo
+++ b/net/dhcpcd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dhcpcd-6.10.1.tar.xz) = 284abf8c3be0580bbac5eaca95359346ab0d78d4072317b6ce87cc68f2e8ae7b
-SIZE (dhcpcd-6.10.1.tar.xz) = 180112
+SHA256 (dhcpcd-6.10.2.tar.xz) = 64a0ff84ba7f1e820b2ccfe08980b3b73e96bb072274b21de523f1da83a94e09
+SIZE (dhcpcd-6.10.2.tar.xz) = 184512
diff --git a/net/dhcpcd/files/dhcpcd.in b/net/dhcpcd/files/dhcpcd.in
index 6862295f8e46..e9695b34f5e4 100644
--- a/net/dhcpcd/files/dhcpcd.in
+++ b/net/dhcpcd/files/dhcpcd.in
@@ -11,26 +11,30 @@ name="dhcpcd"
ifn="$2"
command="%%PREFIX%%/sbin/dhcpcd"
command_args="$ifn"
-pidfile="/var/run/dhcpcd-$ifn.pid"
+if [ -n "$ifn" ]; then
+ specific="$(get_if_var $ifn dhcpcd_flags_IF)"
+ if [ -z "$flags" -a -n "$specific" ]; then
+ rc_flags="$specific"
+ fi
+ pidfile="/var/run/dhcpcd-$ifn.pid"
+else
+ pidfile="$($command -P $rc_flags)"
+fi
start_precmd="dhcpcd_precmd"
dhcpcd_precmd()
{
- # Override for $ifn specific flags (see rc.subr for $flags setting)
- specific=`get_if_var $ifn dhcpcd_flags_IF`
- if [ -z "$flags" -a -n "$specific" ]; then
- rc_flags=$specific
- fi
-
# dhcpcd may need local binaries
- export PATH=${PATH}:%%PREFIX%%/sbin
+ export PATH=${PATH}:/usr/local/sbin
}
load_rc_config $name
load_rc_config network
-if ! dhcpif $ifn; then
- return 1
+if [ -n "$ifn" ]; then
+ if ! dhcpif $ifn; then
+ err 1 "$ifn is not enabled for DHCP"
+ fi
fi
run_rc_command "$1"
diff --git a/net/dhcpcd/files/patch-dhcpcd.conf b/net/dhcpcd/files/patch-dhcpcd.conf
deleted file mode 100644
index 9c18804e5430..000000000000
--- a/net/dhcpcd/files/patch-dhcpcd.conf
+++ /dev/null
@@ -1,13 +0,0 @@
-Disable private SLAAC addresses as that would cause dhcpcd to own the routes
-by default.
-
-See http://bugs.freebsd.org/bugzilla/show_bug.cgi?id=194485
-
---- dhcpcd.conf.orig 2016-01-07 16:47:19 UTC
-+++ dhcpcd.conf
-@@ -35,4 +35,4 @@ option interface_mtu
- require dhcp_server_identifier
-
- # Generate Stable Private IPv6 Addresses instead of hardware based ones
--slaac private
-+#slaac private
diff --git a/net/dhcpcd/pkg-message b/net/dhcpcd/pkg-message
index 25ede5c4556b..05dbb544a189 100644
--- a/net/dhcpcd/pkg-message
+++ b/net/dhcpcd/pkg-message
@@ -1,4 +1,6 @@
The default FreeBSD kernel does not allow userland to provide IPv6
-Prefix Routes, which dhcpcd needs to do when running the default configuration.
+Prefix Routes when the kernel is handling Router Advertisements.
+The default dhcpcd configuration will disable the kernel from handling
+Router Advertisements.
See http://bugs.freebsd.org/bugzilla/show_bug.cgi?id=194485 for a patch.