aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile18
-rw-r--r--net/hs-aws/Makefile28
-rw-r--r--net/hs-aws/distinfo3
-rw-r--r--net/hs-aws/pkg-descr4
-rw-r--r--net/hs-bsb-http-chunked/Makefile17
-rw-r--r--net/hs-bsb-http-chunked/distinfo3
-rw-r--r--net/hs-bsb-http-chunked/pkg-descr4
-rw-r--r--net/hs-connection/Makefile21
-rw-r--r--net/hs-connection/distinfo3
-rw-r--r--net/hs-connection/pkg-descr6
-rw-r--r--net/hs-gsasl/Makefile20
-rw-r--r--net/hs-gsasl/distinfo3
-rw-r--r--net/hs-gsasl/pkg-descr3
-rw-r--r--net/hs-hoauth2/Makefile22
-rw-r--r--net/hs-hoauth2/distinfo3
-rw-r--r--net/hs-hoauth2/files/patch-hoauth2.cabal26
-rw-r--r--net/hs-hoauth2/pkg-descr3
-rw-r--r--net/hs-hostname/Makefile17
-rw-r--r--net/hs-hostname/distinfo3
-rw-r--r--net/hs-hostname/pkg-descr4
-rw-r--r--net/hs-iproute/Makefile19
-rw-r--r--net/hs-iproute/distinfo3
-rw-r--r--net/hs-iproute/pkg-descr5
-rw-r--r--net/hs-maccatcher/Makefile17
-rw-r--r--net/hs-maccatcher/distinfo3
-rw-r--r--net/hs-maccatcher/pkg-descr3
-rw-r--r--net/hs-network-info/Makefile17
-rw-r--r--net/hs-network-info/distinfo3
-rw-r--r--net/hs-network-info/pkg-descr6
-rw-r--r--net/hs-network-multicast/Makefile17
-rw-r--r--net/hs-network-multicast/distinfo3
-rw-r--r--net/hs-network-multicast/pkg-descr4
-rw-r--r--net/hs-network-protocol-xmpp/Makefile20
-rw-r--r--net/hs-network-protocol-xmpp/distinfo3
-rw-r--r--net/hs-network-protocol-xmpp/pkg-descr3
-rw-r--r--net/hs-network-uri/Makefile17
-rw-r--r--net/hs-network-uri/distinfo3
-rw-r--r--net/hs-network-uri/pkg-descr3
-rw-r--r--net/hs-pcap/Makefile20
-rw-r--r--net/hs-pcap/distinfo3
-rw-r--r--net/hs-pcap/pkg-descr3
-rw-r--r--net/hs-publicsuffixlist/Makefile19
-rw-r--r--net/hs-publicsuffixlist/distinfo3
-rw-r--r--net/hs-publicsuffixlist/pkg-descr3
-rw-r--r--net/hs-resolv/Makefile19
-rw-r--r--net/hs-resolv/distinfo3
-rw-r--r--net/hs-resolv/files/patch-resolv.cabal16
-rw-r--r--net/hs-resolv/pkg-descr5
-rw-r--r--net/hs-sendfile/Makefile19
-rw-r--r--net/hs-sendfile/distinfo3
-rw-r--r--net/hs-sendfile/pkg-descr7
-rw-r--r--net/hs-simple-sendfile/Makefile19
-rw-r--r--net/hs-simple-sendfile/distinfo3
-rw-r--r--net/hs-simple-sendfile/pkg-descr4
-rw-r--r--net/hs-socks/Makefile19
-rw-r--r--net/hs-socks/distinfo3
-rw-r--r--net/hs-socks/pkg-descr3
57 files changed, 0 insertions, 534 deletions
diff --git a/net/Makefile b/net/Makefile
index ef8458e65358..b754cebc49e8 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -239,25 +239,7 @@
SUBDIR += hostapd
SUBDIR += howl
SUBDIR += hping
- SUBDIR += hs-aws
- SUBDIR += hs-bsb-http-chunked
- SUBDIR += hs-connection
- SUBDIR += hs-gsasl
- SUBDIR += hs-hoauth2
- SUBDIR += hs-hostname
- SUBDIR += hs-iproute
- SUBDIR += hs-maccatcher
SUBDIR += hs-network
- SUBDIR += hs-network-info
- SUBDIR += hs-network-multicast
- SUBDIR += hs-network-protocol-xmpp
- SUBDIR += hs-network-uri
- SUBDIR += hs-pcap
- SUBDIR += hs-publicsuffixlist
- SUBDIR += hs-resolv
- SUBDIR += hs-sendfile
- SUBDIR += hs-simple-sendfile
- SUBDIR += hs-socks
SUBDIR += hsflowd
SUBDIR += htpdate
SUBDIR += http_ping
diff --git a/net/hs-aws/Makefile b/net/hs-aws/Makefile
deleted file mode 100644
index 7f537f384c70..000000000000
--- a/net/hs-aws/Makefile
+++ /dev/null
@@ -1,28 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= aws
-PORTVERSION= 0.20
-PORTREVISION= 1
-CATEGORIES= net haskell
-
-MAINTAINER= haskell@FreeBSD.org
-COMMENT= Amazon Web Services (AWS) for Haskell
-
-LICENSE= BSD3CLAUSE
-
-DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
-EXPIRATION_DATE= 2019-04-14
-
-USE_CABAL= aeson>=0.6 attoparsec>=0.11 base16-bytestring \
- base64-bytestring blaze-builder>=0.2.1.4 byteable \
- case-insensitive>=0.2 cereal>=0.3 conduit>=1.1 \
- conduit-extra>=1.1 cryptohash>=0.11 data-default>=0.5.3 \
- http-conduit>=2.1 http-types>=0.7 lifted-base>=0.1 \
- monad-control>=0.3 mtl network resourcet>=1.1 safe>=0.3 \
- scientific>=0.3 tagged>=0.7 unordered-containers>=0.2 \
- utf8-string>=0.3 vector>=0.10 xml-conduit>=1.2
-
-FLAGS_DISABLE= examples
-
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
-.include <bsd.port.mk>
diff --git a/net/hs-aws/distinfo b/net/hs-aws/distinfo
deleted file mode 100644
index cb6c9b52d2a5..000000000000
--- a/net/hs-aws/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1531827848
-SHA256 (cabal/aws-0.20.tar.gz) = c079d860d6bf235b134286fb8620d1539664df52dce1146d463cc4ebeb52975f
-SIZE (cabal/aws-0.20.tar.gz) = 104559
diff --git a/net/hs-aws/pkg-descr b/net/hs-aws/pkg-descr
deleted file mode 100644
index 56ca08a30e88..000000000000
--- a/net/hs-aws/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-Bindings for Amazon Web Services (AWS), with the aim of supporting all
-AWS services.
-
-WWW: https://github.com/aristidb/aws
diff --git a/net/hs-bsb-http-chunked/Makefile b/net/hs-bsb-http-chunked/Makefile
deleted file mode 100644
index 535c3a7f6b28..000000000000
--- a/net/hs-bsb-http-chunked/Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= bsb-http-chunked
-PORTVERSION= 0.0.0.4
-PORTREVISION= 1
-CATEGORIES= net haskell
-
-MAINTAINER= haskell@FreeBSD.org
-COMMENT= Chunked HTTP transfer encoding for bytestring builders
-
-LICENSE= BSD3CLAUSE
-
-DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
-EXPIRATION_DATE= 2019-04-14
-
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
-.include <bsd.port.mk>
diff --git a/net/hs-bsb-http-chunked/distinfo b/net/hs-bsb-http-chunked/distinfo
deleted file mode 100644
index 5c8f04d8c17b..000000000000
--- a/net/hs-bsb-http-chunked/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1545495255
-SHA256 (cabal/bsb-http-chunked-0.0.0.4.tar.gz) = 148309e23eb8b261c1de374712372d62d8c8dc8ee504c392809c7ec33c0a0e7c
-SIZE (cabal/bsb-http-chunked-0.0.0.4.tar.gz) = 6630
diff --git a/net/hs-bsb-http-chunked/pkg-descr b/net/hs-bsb-http-chunked/pkg-descr
deleted file mode 100644
index 6e56ac79392d..000000000000
--- a/net/hs-bsb-http-chunked/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-This library contains functions for encoding bytestring builders for
-chunked HTTP/1.1 transfer.
-
-WWW: https://github.com/sjakobi/bsb-http-chunked
diff --git a/net/hs-connection/Makefile b/net/hs-connection/Makefile
deleted file mode 100644
index f44d8b23f6e1..000000000000
--- a/net/hs-connection/Makefile
+++ /dev/null
@@ -1,21 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= connection
-PORTVERSION= 0.2.8
-PORTREVISION= 4
-CATEGORIES= net haskell
-
-MAINTAINER= haskell@FreeBSD.org
-COMMENT= Simple and easy network connections API
-
-LICENSE= BSD3CLAUSE
-
-DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
-EXPIRATION_DATE= 2019-04-14
-
-USE_CABAL= byteable data-default-class network>=2.3 socks>=0.4 \
- tls>=1.3 x509>=1.5 x509-store>=1.5 x509-system>=1.5 \
- x509-validation>=1.5
-
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
-.include <bsd.port.mk>
diff --git a/net/hs-connection/distinfo b/net/hs-connection/distinfo
deleted file mode 100644
index 473b603031b1..000000000000
--- a/net/hs-connection/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1499623591
-SHA256 (cabal/connection-0.2.8.tar.gz) = 70b1f44e8786320c18b26fc5d4ec115fc8ac016ba1f852fa8137f55d785a93eb
-SIZE (cabal/connection-0.2.8.tar.gz) = 8695
diff --git a/net/hs-connection/pkg-descr b/net/hs-connection/pkg-descr
deleted file mode 100644
index db7604fcd5fc..000000000000
--- a/net/hs-connection/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-Simple network library for all your connection need. Features: Really
-simple to use, SSL/TLS, SOCKS. This library provides a very simple api
-to create sockets to a destination with the choice of SSL/TLS, and
-SOCKS.
-
-WWW: https://github.com/vincenthz/hs-connection
diff --git a/net/hs-gsasl/Makefile b/net/hs-gsasl/Makefile
deleted file mode 100644
index a88b138e3d59..000000000000
--- a/net/hs-gsasl/Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= gsasl
-PORTVERSION= 0.3.6
-PORTREVISION= 5
-CATEGORIES= net haskell
-
-MAINTAINER= haskell@FreeBSD.org
-COMMENT= Bindings for GNU libgsasl
-
-LICENSE= GPLv3
-
-DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
-EXPIRATION_DATE= 2019-04-14
-
-USES= pkgconfig
-LIB_DEPENDS= libgsasl.so:security/gsasl
-
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
-.include <bsd.port.mk>
diff --git a/net/hs-gsasl/distinfo b/net/hs-gsasl/distinfo
deleted file mode 100644
index 2fae5afbea2f..000000000000
--- a/net/hs-gsasl/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1499623591
-SHA256 (cabal/gsasl-0.3.6.tar.gz) = 786036025e5d5649c029c1db23c395e1592c073a58848ae4afe4f2797de1f931
-SIZE (cabal/gsasl-0.3.6.tar.gz) = 20170
diff --git a/net/hs-gsasl/pkg-descr b/net/hs-gsasl/pkg-descr
deleted file mode 100644
index 245ab400f884..000000000000
--- a/net/hs-gsasl/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-Bindings for GNU libgsasl.
-
-WWW: https://john-millikin.com/software/haskell-gsasl/
diff --git a/net/hs-hoauth2/Makefile b/net/hs-hoauth2/Makefile
deleted file mode 100644
index 817f079d5568..000000000000
--- a/net/hs-hoauth2/Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= hoauth2
-PORTVERSION= 1.7.1
-PORTREVISION= 2
-CATEGORIES= net haskell
-
-MAINTAINER= haskell@FreeBSD.org
-COMMENT= Haskell OAuth2 authentication
-
-LICENSE= BSD3CLAUSE
-
-DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
-EXPIRATION_DATE= 2019-04-14
-
-USE_CABAL= aeson http-conduit http-types microlens unordered-containers \
- uri-bytestring uri-bytestring-aeson wai warp
-
-FLAGS_DISABLE= test
-
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
-.include <bsd.port.mk>
diff --git a/net/hs-hoauth2/distinfo b/net/hs-hoauth2/distinfo
deleted file mode 100644
index c67087045fb9..000000000000
--- a/net/hs-hoauth2/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1525036387
-SHA256 (cabal/hoauth2-1.7.1.tar.gz) = bae84321fb0c90013677d6abe754774f05fbb3271ced0844df725ca4edb38216
-SIZE (cabal/hoauth2-1.7.1.tar.gz) = 18045
diff --git a/net/hs-hoauth2/files/patch-hoauth2.cabal b/net/hs-hoauth2/files/patch-hoauth2.cabal
deleted file mode 100644
index 203ffab8d5d8..000000000000
--- a/net/hs-hoauth2/files/patch-hoauth2.cabal
+++ /dev/null
@@ -1,26 +0,0 @@
---- hoauth2.cabal.orig 2018-04-29 21:29:58 UTC
-+++ hoauth2.cabal
-@@ -77,12 +77,12 @@ Library
- bytestring >= 0.9 && < 0.11,
- http-conduit >= 2.1 && < 2.4,
- http-types >= 0.11 && < 0.13,
-- aeson >= 0.11 && < 1.3,
-+ aeson >= 0.11 && < 1.4,
- unordered-containers >= 0.2.5,
- uri-bytestring >= 0.2.3.1 && < 0.4,
- uri-bytestring-aeson >= 0.1 && < 0.2,
- microlens >= 0.4.0 && < 0.5,
-- exceptions >= 0.8.3 && < 0.10
-+ exceptions >= 0.8.3 && < 0.11
-
- if impl(ghc >= 6.12.0)
- ghc-options: -Wall -fwarn-tabs -funbox-strict-fields
-@@ -125,7 +125,7 @@ Executable demo-server
- wai >= 3.2 && < 3.3,
- warp >= 3.2 && < 3.3,
- containers >= 0.4 && < 0.6,
-- aeson >= 0.11 && < 1.3,
-+ aeson >= 0.11 && < 1.4,
- microlens >= 0.4.0 && < 0.5,
- unordered-containers >= 0.2.8 && < 0.2.9,
- wai-extra >= 3.0.21.0 && < 3.0.22.0,
diff --git a/net/hs-hoauth2/pkg-descr b/net/hs-hoauth2/pkg-descr
deleted file mode 100644
index 9bcdafb2f854..000000000000
--- a/net/hs-hoauth2/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-Haskell OAuth2 authentication client.
-
-WWW: https://github.com/freizl/hoauth2
diff --git a/net/hs-hostname/Makefile b/net/hs-hostname/Makefile
deleted file mode 100644
index 2db592c256ba..000000000000
--- a/net/hs-hostname/Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= hostname
-PORTVERSION= 1.0
-PORTREVISION= 20
-CATEGORIES= net haskell
-
-MAINTAINER= haskell@FreeBSD.org
-COMMENT= Cross-platform means of determining the hostname
-
-LICENSE= BSD3CLAUSE
-
-DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
-EXPIRATION_DATE= 2019-04-14
-
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
-.include <bsd.port.mk>
diff --git a/net/hs-hostname/distinfo b/net/hs-hostname/distinfo
deleted file mode 100644
index c3614627da68..000000000000
--- a/net/hs-hostname/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1499623591
-SHA256 (cabal/hostname-1.0.tar.gz) = 9b43dab1b6da521f35685b20555da00738c8e136eb972458c786242406a9cf5c
-SIZE (cabal/hostname-1.0.tar.gz) = 1982
diff --git a/net/hs-hostname/pkg-descr b/net/hs-hostname/pkg-descr
deleted file mode 100644
index 828c88d112a3..000000000000
--- a/net/hs-hostname/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-A very simple package providing a cross-platform means of determining
-the hostname.
-
-WWW: http://hackage.haskell.org/package/hostname
diff --git a/net/hs-iproute/Makefile b/net/hs-iproute/Makefile
deleted file mode 100644
index 1a95f5202eb9..000000000000
--- a/net/hs-iproute/Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= iproute
-PORTVERSION= 1.7.1
-PORTREVISION= 4
-CATEGORIES= net haskell
-
-MAINTAINER= haskell@FreeBSD.org
-COMMENT= IP Routing Table
-
-LICENSE= BSD3CLAUSE
-
-DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
-EXPIRATION_DATE= 2019-04-14
-
-USE_CABAL= appar byteorder network
-
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
-.include <bsd.port.mk>
diff --git a/net/hs-iproute/distinfo b/net/hs-iproute/distinfo
deleted file mode 100644
index f9baa1c8af00..000000000000
--- a/net/hs-iproute/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1499623592
-SHA256 (cabal/iproute-1.7.1.tar.gz) = 57b8d03ca8ce92f8ec1334564f3edff53a0621ccbc43c00ba02eaa5007ee3eee
-SIZE (cabal/iproute-1.7.1.tar.gz) = 11974
diff --git a/net/hs-iproute/pkg-descr b/net/hs-iproute/pkg-descr
deleted file mode 100644
index 533e3608fef3..000000000000
--- a/net/hs-iproute/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-IP Routing Table is a tree of IP ranges to search one of them on the
-longest match base. It is a kind of TRIE with one way branching removed.
-Both IPv4 and IPv6 are supported.
-
-WWW: http://www.mew.org/~kazu/proj/iproute/
diff --git a/net/hs-maccatcher/Makefile b/net/hs-maccatcher/Makefile
deleted file mode 100644
index e85ce9bde963..000000000000
--- a/net/hs-maccatcher/Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= maccatcher
-PORTVERSION= 2.1.5
-PORTREVISION= 13
-CATEGORIES= net haskell
-
-MAINTAINER= haskell@FreeBSD.org
-COMMENT= Obtain the host MAC address on *NIX and Windows
-
-LICENSE= BSD3CLAUSE
-
-DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
-EXPIRATION_DATE= 2019-04-14
-
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
-.include <bsd.port.mk>
diff --git a/net/hs-maccatcher/distinfo b/net/hs-maccatcher/distinfo
deleted file mode 100644
index 77d4ba088ae6..000000000000
--- a/net/hs-maccatcher/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1499623592
-SHA256 (cabal/maccatcher-2.1.5.tar.gz) = cbafc38151d9c4c17c3055a7f8f0702bf5d7d5240db3369c84326e94ddcaa67c
-SIZE (cabal/maccatcher-2.1.5.tar.gz) = 4947
diff --git a/net/hs-maccatcher/pkg-descr b/net/hs-maccatcher/pkg-descr
deleted file mode 100644
index fb4c6372c111..000000000000
--- a/net/hs-maccatcher/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-Obtain the host MAC address on *NIX and Windows.
-
-WWW: http://hackage.haskell.org/package/maccatcher
diff --git a/net/hs-network-info/Makefile b/net/hs-network-info/Makefile
deleted file mode 100644
index c37f92c2092b..000000000000
--- a/net/hs-network-info/Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= network-info
-PORTVERSION= 0.2.0.10
-PORTREVISION= 1
-CATEGORIES= net haskell
-
-MAINTAINER= haskell@FreeBSD.org
-COMMENT= Access the local computer's basic network configuration
-
-LICENSE= BSD3CLAUSE
-
-DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
-EXPIRATION_DATE= 2019-04-14
-
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
-.include <bsd.port.mk>
diff --git a/net/hs-network-info/distinfo b/net/hs-network-info/distinfo
deleted file mode 100644
index 027be7307e44..000000000000
--- a/net/hs-network-info/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1533828675
-SHA256 (cabal/network-info-0.2.0.10.tar.gz) = 5680f6975d34cf4f81fa7ca0c8efd682261d6a1119e06dece0f67c7bd97fd52a
-SIZE (cabal/network-info-0.2.0.10.tar.gz) = 6278
diff --git a/net/hs-network-info/pkg-descr b/net/hs-network-info/pkg-descr
deleted file mode 100644
index cfa6eee39d35..000000000000
--- a/net/hs-network-info/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-This library provides simple read-only access to the local computer's
-networking configuration. It is currently capable of getting a list of
-all the network interfaces and their respective IPv4, IPv6 and MAC
-addresses.
-
-WWW: https://github.com/jystic/network-info
diff --git a/net/hs-network-multicast/Makefile b/net/hs-network-multicast/Makefile
deleted file mode 100644
index 50a5a4085271..000000000000
--- a/net/hs-network-multicast/Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= network-multicast
-PORTVERSION= 0.2.0
-PORTREVISION= 4
-CATEGORIES= net haskell
-
-MAINTAINER= haskell@FreeBSD.org
-COMMENT= Simple multicast library
-
-DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
-EXPIRATION_DATE= 2019-04-14
-
-USE_CABAL= network
-
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
-.include <bsd.port.mk>
diff --git a/net/hs-network-multicast/distinfo b/net/hs-network-multicast/distinfo
deleted file mode 100644
index 152158ef5d42..000000000000
--- a/net/hs-network-multicast/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1499623594
-SHA256 (cabal/network-multicast-0.2.0.tar.gz) = 0f3b50abc3a401c20cc6a0ec51a49d2a48e5b467d9fbd63b7cf803165fe975f2
-SIZE (cabal/network-multicast-0.2.0.tar.gz) = 2986
diff --git a/net/hs-network-multicast/pkg-descr b/net/hs-network-multicast/pkg-descr
deleted file mode 100644
index 16f9a03ff3fa..000000000000
--- a/net/hs-network-multicast/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-The "Network.Multicast" module is for sending UDP datagrams over multicast
-(class D) addresses.
-
-WWW: http://hackage.haskell.org/package/network-multicast
diff --git a/net/hs-network-protocol-xmpp/Makefile b/net/hs-network-protocol-xmpp/Makefile
deleted file mode 100644
index 94d04136ae31..000000000000
--- a/net/hs-network-protocol-xmpp/Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= network-protocol-xmpp
-PORTVERSION= 0.4.8
-PORTREVISION= 6
-CATEGORIES= net haskell
-
-MAINTAINER= haskell@FreeBSD.org
-COMMENT= Client library for the XMPP protocol
-
-LICENSE= GPLv3
-
-DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
-EXPIRATION_DATE= 2019-04-14
-
-USE_CABAL= gnuidn>=0.2 gnutls>=0.1.4 gsasl>=0.3 libxml-sax>=0.7 \
- monads-tf>=0.1 network>=2.2 xml-types>=0.3
-
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
-.include <bsd.port.mk>
diff --git a/net/hs-network-protocol-xmpp/distinfo b/net/hs-network-protocol-xmpp/distinfo
deleted file mode 100644
index dd6a11d3b448..000000000000
--- a/net/hs-network-protocol-xmpp/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1499623595
-SHA256 (cabal/network-protocol-xmpp-0.4.8.tar.gz) = ea7729e00452da11ed489a71f482e0aa082b0fb872eedca2e3722a05fd421e1e
-SIZE (cabal/network-protocol-xmpp-0.4.8.tar.gz) = 24289
diff --git a/net/hs-network-protocol-xmpp/pkg-descr b/net/hs-network-protocol-xmpp/pkg-descr
deleted file mode 100644
index cb14430f34cd..000000000000
--- a/net/hs-network-protocol-xmpp/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-Client library for the XMPP protocol.
-
-WWW: https://john-millikin.com/software/haskell-xmpp/
diff --git a/net/hs-network-uri/Makefile b/net/hs-network-uri/Makefile
deleted file mode 100644
index d61ecd01ffeb..000000000000
--- a/net/hs-network-uri/Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= network-uri
-PORTVERSION= 2.6.1.0
-PORTREVISION= 4
-CATEGORIES= net haskell
-
-MAINTAINER= haskell@FreeBSD.org
-COMMENT= URI manipulation
-
-LICENSE= BSD3CLAUSE
-
-DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
-EXPIRATION_DATE= 2019-04-14
-
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
-.include <bsd.port.mk>
diff --git a/net/hs-network-uri/distinfo b/net/hs-network-uri/distinfo
deleted file mode 100644
index 4509413bb10a..000000000000
--- a/net/hs-network-uri/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1499623596
-SHA256 (cabal/network-uri-2.6.1.0.tar.gz) = 423e0a2351236f3fcfd24e39cdbc38050ec2910f82245e69ca72a661f7fc47f0
-SIZE (cabal/network-uri-2.6.1.0.tar.gz) = 27262
diff --git a/net/hs-network-uri/pkg-descr b/net/hs-network-uri/pkg-descr
deleted file mode 100644
index 887de7f00388..000000000000
--- a/net/hs-network-uri/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-This package provides an URI manipulation inteface.
-
-WWW: https://github.com/haskell/network-uri
diff --git a/net/hs-pcap/Makefile b/net/hs-pcap/Makefile
deleted file mode 100644
index 235f360032f5..000000000000
--- a/net/hs-pcap/Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
-# Created by: Ju Pengfei <jupengfei@gmail.com>
-# $FreeBSD$
-
-PORTNAME= pcap
-PORTVERSION= 0.4.5.2
-PORTREVISION= 14
-CATEGORIES= net haskell
-
-MAINTAINER= haskell@FreeBSD.org
-COMMENT= System-independent interface for user-level packet capture
-
-LICENSE= BSD3CLAUSE
-
-DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
-EXPIRATION_DATE= 2019-04-14
-
-USE_CABAL= network
-
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
-.include <bsd.port.mk>
diff --git a/net/hs-pcap/distinfo b/net/hs-pcap/distinfo
deleted file mode 100644
index fd8c65aa0716..000000000000
--- a/net/hs-pcap/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1499623596
-SHA256 (cabal/pcap-0.4.5.2.tar.gz) = e7e92e6ff4bffa22102335a38dabb97fd0771fdf3b75d45cd7c1708c85e1cd5f
-SIZE (cabal/pcap-0.4.5.2.tar.gz) = 49414
diff --git a/net/hs-pcap/pkg-descr b/net/hs-pcap/pkg-descr
deleted file mode 100644
index c21ab1a63c6a..000000000000
--- a/net/hs-pcap/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-A system-independent interface for user-level packet capture.
-
-WWW: https://github.com/bos/pcap
diff --git a/net/hs-publicsuffixlist/Makefile b/net/hs-publicsuffixlist/Makefile
deleted file mode 100644
index 0e48c8820897..000000000000
--- a/net/hs-publicsuffixlist/Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= publicsuffixlist
-PORTVERSION= 0.1
-PORTREVISION= 12
-CATEGORIES= net haskell
-
-MAINTAINER= haskell@FreeBSD.org
-COMMENT= Is a given string a domain suffix?
-
-LICENSE= BSD3CLAUSE
-
-DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
-EXPIRATION_DATE= 2019-04-14
-
-USE_CABAL= cereal data-default utf8-string
-
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
-.include <bsd.port.mk>
diff --git a/net/hs-publicsuffixlist/distinfo b/net/hs-publicsuffixlist/distinfo
deleted file mode 100644
index 8c836299b468..000000000000
--- a/net/hs-publicsuffixlist/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1499623596
-SHA256 (cabal/publicsuffixlist-0.1.tar.gz) = b37fbe099748e2a3a5a3b6661911d72749c2ec24d88ee686ae125de91fac7955
-SIZE (cabal/publicsuffixlist-0.1.tar.gz) = 72704
diff --git a/net/hs-publicsuffixlist/pkg-descr b/net/hs-publicsuffixlist/pkg-descr
deleted file mode 100644
index db2bcf2ee94a..000000000000
--- a/net/hs-publicsuffixlist/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-Is a given string a domain suffix?
-
-WWW: https://github.com/litherum/publicsuffixlist
diff --git a/net/hs-resolv/Makefile b/net/hs-resolv/Makefile
deleted file mode 100644
index 7f0a69c66402..000000000000
--- a/net/hs-resolv/Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= resolv
-PORTVERSION= 0.1.1.1
-PORTREVISION= 3
-CATEGORIES= net haskell
-
-MAINTAINER= haskell@FreeBSD.org
-COMMENT= Domain Name Service (DNS) lookup via the libresolv standard library routines
-
-LICENSE= GPLv3
-
-DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
-EXPIRATION_DATE= 2019-04-14
-
-USE_CABAL= base16-bytestring
-
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
-.include <bsd.port.mk>
diff --git a/net/hs-resolv/distinfo b/net/hs-resolv/distinfo
deleted file mode 100644
index f2b0e84ec838..000000000000
--- a/net/hs-resolv/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1523298714
-SHA256 (cabal/resolv-0.1.1.1.tar.gz) = 49b12ed2b175cca3f885c06ca6906cde1245c02b6f98f2a95fc20d6a8ae40772
-SIZE (cabal/resolv-0.1.1.1.tar.gz) = 149436
diff --git a/net/hs-resolv/files/patch-resolv.cabal b/net/hs-resolv/files/patch-resolv.cabal
deleted file mode 100644
index e4b5d13960e6..000000000000
--- a/net/hs-resolv/files/patch-resolv.cabal
+++ /dev/null
@@ -1,16 +0,0 @@
---- resolv.cabal.orig 2017-10-26 22:24:39 UTC
-+++ resolv.cabal
-@@ -78,11 +78,11 @@ library
- Network.DNS.FFI
- Compat
-
-- build-depends: base >= 4.5 && <4.11
-+ build-depends: base >= 4.5 && <4.13
- , base16-bytestring == 0.1.*
- , binary >= 0.7.3 && < 0.9
- , bytestring >= 0.9.2 && < 0.11
-- , containers >= 0.4.2.1 && < 0.6
-+ , containers >= 0.4.2.1 && < 0.7
-
- ghc-options: -Wall
- include-dirs: cbits
diff --git a/net/hs-resolv/pkg-descr b/net/hs-resolv/pkg-descr
deleted file mode 100644
index 2eeb4e6fcaa5..000000000000
--- a/net/hs-resolv/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-This package implements an API for accessing the Domain Name Service (DNS)
-resolver service via the standard libresolv system library (whose API is
-often available directly via the standard libc C library) on Unix systems.
-
-WWW: https://github.com/hvr/resolv
diff --git a/net/hs-sendfile/Makefile b/net/hs-sendfile/Makefile
deleted file mode 100644
index 4fca3b35dfa9..000000000000
--- a/net/hs-sendfile/Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= sendfile
-PORTVERSION= 0.7.9
-PORTREVISION= 13
-CATEGORIES= net haskell
-
-MAINTAINER= haskell@FreeBSD.org
-COMMENT= Portable sendfile library
-
-LICENSE= BSD3CLAUSE
-
-DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
-EXPIRATION_DATE= 2019-04-14
-
-USE_CABAL= network>=2
-
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
-.include <bsd.port.mk>
diff --git a/net/hs-sendfile/distinfo b/net/hs-sendfile/distinfo
deleted file mode 100644
index 6cfd4e9fb9f7..000000000000
--- a/net/hs-sendfile/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1499623596
-SHA256 (cabal/sendfile-0.7.9.tar.gz) = 102fdf6db8c00f5a5981c6eed5acba1368a2d79b2970ce5b22ceb180aa0fdc42
-SIZE (cabal/sendfile-0.7.9.tar.gz) = 10656
diff --git a/net/hs-sendfile/pkg-descr b/net/hs-sendfile/pkg-descr
deleted file mode 100644
index 8412a9943894..000000000000
--- a/net/hs-sendfile/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-A library which exposes zero-copy sendfile functionality in a portable
-way. If a platform does not support sendfile, a fallback implementation
-in haskell is provided. Currently supported platforms: Windows 2000+
-(Native), Linux 2.6+ (Native), FreeBSD (Native), OS-X 10.5+ (Native),
-Everything else (Portable Haskell code).
-
-WWW: http://hub.darcs.net/stepcut/sendfile
diff --git a/net/hs-simple-sendfile/Makefile b/net/hs-simple-sendfile/Makefile
deleted file mode 100644
index 5d624de4837f..000000000000
--- a/net/hs-simple-sendfile/Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= simple-sendfile
-PORTVERSION= 0.2.25
-PORTREVISION= 4
-CATEGORIES= net haskell
-
-MAINTAINER= haskell@FreeBSD.org
-COMMENT= Cross-platform library for the sendfile() system call
-
-LICENSE= BSD3CLAUSE
-
-DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
-EXPIRATION_DATE= 2019-04-14
-
-USE_CABAL= conduit>=1.0 conduit-extra>=1.0 network resourcet
-
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
-.include <bsd.port.mk>
diff --git a/net/hs-simple-sendfile/distinfo b/net/hs-simple-sendfile/distinfo
deleted file mode 100644
index 11ec92b50c80..000000000000
--- a/net/hs-simple-sendfile/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1499623597
-SHA256 (cabal/simple-sendfile-0.2.25.tar.gz) = 0ae68821cd828b29772654b5613d514a421b1b1440d82a4b610339e67a92294d
-SIZE (cabal/simple-sendfile-0.2.25.tar.gz) = 343509
diff --git a/net/hs-simple-sendfile/pkg-descr b/net/hs-simple-sendfile/pkg-descr
deleted file mode 100644
index 3365cbb9165a..000000000000
--- a/net/hs-simple-sendfile/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-Cross-platform library for the sendfile() system call. This library tries
-to call minimum system calls which are the bottleneck of web servers.
-
-WWW: http://hackage.haskell.org/package/simple-sendfile
diff --git a/net/hs-socks/Makefile b/net/hs-socks/Makefile
deleted file mode 100644
index 04379cfe594f..000000000000
--- a/net/hs-socks/Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= socks
-PORTVERSION= 0.5.5
-PORTREVISION= 4
-CATEGORIES= net haskell
-
-MAINTAINER= haskell@FreeBSD.org
-COMMENT= Socks proxy (version 5) implementation
-
-LICENSE= BSD3CLAUSE
-
-DEPRECATED= Haskell libraries are getting pushed out of the ports tree. If you are using this port for development, consider switching to cabal sandboxes (old way), cabal new-build (new way), or use devel/stack. If you believe this port shouldn't be removed, contact haskell@FreeBSD.org
-EXPIRATION_DATE= 2019-04-14
-
-USE_CABAL= cereal>=0.3.1 network>=2.3
-
-.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
-.include <bsd.port.mk>
diff --git a/net/hs-socks/distinfo b/net/hs-socks/distinfo
deleted file mode 100644
index e3fac1b9e90a..000000000000
--- a/net/hs-socks/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1499623597
-SHA256 (cabal/socks-0.5.5.tar.gz) = 2647ea93e21ad1dfd77e942c022c8707e468d25e1ff672a88be82508034fc868
-SIZE (cabal/socks-0.5.5.tar.gz) = 10159
diff --git a/net/hs-socks/pkg-descr b/net/hs-socks/pkg-descr
deleted file mode 100644
index 161b203c7a7c..000000000000
--- a/net/hs-socks/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-Socks proxy (version 5) implementation.
-
-WWW: https://github.com/vincenthz/hs-socks