aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/echoping/Makefile34
-rw-r--r--net/echoping/pkg-plist12
2 files changed, 38 insertions, 8 deletions
diff --git a/net/echoping/Makefile b/net/echoping/Makefile
index b505b99c9ad2..d1aa8775812c 100644
--- a/net/echoping/Makefile
+++ b/net/echoping/Makefile
@@ -7,7 +7,7 @@
PORTNAME= echoping
PORTVERSION= 5.99.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.internatif.org/pub/unix/echoping/
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,12 +19,38 @@ COMMENT= A ping-like program that uses tcp and/or http
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
idn.16:${PORTSDIR}/dns/libidn
-USE_OPENLDAP= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-http --enable-icp --enable-smtp --with-ssl \
--enable-ttcp --enable-tos --with-libidn=${LOCALBASE}
-MAN1= echoping.1 echoping_dns.1 echoping_random.1 echoping_whois.1 echoping_ldap.1
+PING_PLUGINS= dns random whois
+
+MAN1= echoping.1 echoping_dns.1 echoping_random.1 echoping_whois.1
+
+OPTIONS= LDAP "Enable LDAP plug-in" on \
+ PGSQL "Enable PostgreSQL plug-in" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_LDAP)
+USE_OPENLDAP= yes
+MAN1+= echoping_ldap.1
+PING_PLUGINS+= ldap
+PLIST_SUB= WITH_LDAP=""
+.else
+PLIST_SUB= WITH_LDAP="@comment "
+.endif
+
+.if defined(WITH_PGSQL)
+USE_PGSQL= yes
+MAN1+= echoping_postgresql.1
+PING_PLUGINS+= postgresql
+PLIST_SUB+= WITH_PGSQL=""
+.else
+PLIST_SUB+= WITH_PGSQL="@comment "
+.endif
+
+CONFIGURE_ARGS+=--enable-plugin="${PING_PLUGINS}"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/echoping/pkg-plist b/net/echoping/pkg-plist
index cdb2936112bb..9efad7e7b890 100644
--- a/net/echoping/pkg-plist
+++ b/net/echoping/pkg-plist
@@ -3,10 +3,14 @@ lib/echoping/dns.a
lib/echoping/dns.la
lib/echoping/dns.so
lib/echoping/dns.so.0
-lib/echoping/ldap.a
-lib/echoping/ldap.la
-lib/echoping/ldap.so
-lib/echoping/ldap.so.0
+%%WITH_LDAP%%lib/echoping/ldap.a
+%%WITH_LDAP%%lib/echoping/ldap.la
+%%WITH_LDAP%%lib/echoping/ldap.so
+%%WITH_LDAP%%lib/echoping/ldap.so.0
+%%WITH_PGSQL%%lib/echoping/postgresql.a
+%%WITH_PGSQL%%lib/echoping/postgresql.la
+%%WITH_PGSQL%%lib/echoping/postgresql.so
+%%WITH_PGSQL%%lib/echoping/postgresql.so.0
lib/echoping/random.a
lib/echoping/random.la
lib/echoping/random.so