aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/opal/Makefile6
-rw-r--r--net/opal3/Makefile6
2 files changed, 2 insertions, 10 deletions
diff --git a/net/opal/Makefile b/net/opal/Makefile
index 109daf81cc5a..3f9a39f14257 100644
--- a/net/opal/Makefile
+++ b/net/opal/Makefile
@@ -34,10 +34,6 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= Does not build on FreeBSD 4.x, if you manage to make it work, please send a patch to the maintainer: ${MAINTAINER}
-.endif
-
# Avoid build error on 64-bit architectures
.if (${ARCH} == "amd64") || (${ARCH} == "ia64") || (${ARCH} == "sparc64")
CFLAGS+= -fPIC
@@ -50,7 +46,7 @@ CONFIGURE_ARGS+= --enable-h263avcodec=${LOCALBASE}/include/ffmpeg
.ifdef (WITH_SPEEX)
LIB_DEPENDS+= speex.1:${PORTSDIR}/audio/speex
-BUILD_DEPENDS+= ${LOCALBASE}/include/speex/speex_echo.h:${PORTSDIR}/audio/speex-devel
+BUILD_DEPENDS+= ${LOCALBASE}/include/speex/speex_echo.h:${PORTSDIR}/audio/speex
CONFIGURE_ARGS+= --enable-localspeex=no
.else
CONFIGURE_ARGS+= --enable-localspeex=yes
diff --git a/net/opal3/Makefile b/net/opal3/Makefile
index 109daf81cc5a..3f9a39f14257 100644
--- a/net/opal3/Makefile
+++ b/net/opal3/Makefile
@@ -34,10 +34,6 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= Does not build on FreeBSD 4.x, if you manage to make it work, please send a patch to the maintainer: ${MAINTAINER}
-.endif
-
# Avoid build error on 64-bit architectures
.if (${ARCH} == "amd64") || (${ARCH} == "ia64") || (${ARCH} == "sparc64")
CFLAGS+= -fPIC
@@ -50,7 +46,7 @@ CONFIGURE_ARGS+= --enable-h263avcodec=${LOCALBASE}/include/ffmpeg
.ifdef (WITH_SPEEX)
LIB_DEPENDS+= speex.1:${PORTSDIR}/audio/speex
-BUILD_DEPENDS+= ${LOCALBASE}/include/speex/speex_echo.h:${PORTSDIR}/audio/speex-devel
+BUILD_DEPENDS+= ${LOCALBASE}/include/speex/speex_echo.h:${PORTSDIR}/audio/speex
CONFIGURE_ARGS+= --enable-localspeex=no
.else
CONFIGURE_ARGS+= --enable-localspeex=yes