aboutsummaryrefslogtreecommitdiffstats
path: root/news/nn/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'news/nn/Makefile')
-rw-r--r--news/nn/Makefile25
1 files changed, 8 insertions, 17 deletions
diff --git a/news/nn/Makefile b/news/nn/Makefile
index cf162f9b3e56..9f59b8246cdc 100644
--- a/news/nn/Makefile
+++ b/news/nn/Makefile
@@ -1,39 +1,30 @@
# New ports collection makefile for: nn
-# Version required: 6.5.3
+# Version required: 6.5.5
# Date created: 24 September 1994
# Whom: adam
#
# $FreeBSD$
#
-DISTNAME= nn-6.5.3
+DISTNAME= nn-6.5.5
CATEGORIES= news
-MASTER_SITES= ftp://ftp.visi.com/users/mtpins/ \
- ftp://maroon.webmaster.com/pub/nn/
+MASTER_SITES= ftp://ftp.visi.com/users/mtpins/
EXTRACT_SUFX= .tar.Z
-MAINTAINER= ports@FreeBSD.org
-MAINTAINER= jooji@webnology.com
-
-IS_INTERACTIVE= yes
-NO_PACKAGE= posting depends on inews utility, which has poster\'s domain compiled in
+MAINTAINER= jooji@nickelkid.com
MAN1= nn.1 nncheck.1 nngoback.1 nngrab.1 nngrep.1 nnpost.1 \
nntidy.1 nnview.1 nnacct.1m nnadmin.1m nnstats.1m nnusage.1m
MAN8= nnmaster.8 nnspew.8
pre-patch:
- @${CP} ${WRKSRC}/config.h-dist ${WRKSRC}/config.h
+ @${CP} ${WRKSRC}/config.h-dist ${WRKSRC}/config.h.unparsed
pre-build:
- @${CP} ${FILESDIR}/s-freebsd.h ${WRKSRC}/conf
-
-pre-install:
- @${MKDIR} ${PREFIX}/news
- [ ! -f ${WRKDIR}/.install_inews ] || (cd ${WRKSRC}/inews; ${MAKE} all)
- [ ! -f ${WRKDIR}/.install_inews ] || (cd ${WRKSRC}/inews; ${MAKE} install)
+ @${CAT} ${WRKSRC}/config.h.unparsed | ${SED} -e "s#SUB_PREFIX#${PREFIX}#" \
+ | ${SED} -e "s#SUB_MANPREFIX#${MANPREFIX}#" > ${WRKSRC}/config.h
post-install:
- @${CP} ${WRKDIR}/nntp_server ${PREFIX}/etc/nntp_server
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/INSTALL ${DISTNAME} POST-INSTALL
.include <bsd.port.mk>