aboutsummaryrefslogtreecommitdiffstats
path: root/news/nntpcache/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'news/nntpcache/Makefile')
-rw-r--r--news/nntpcache/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/news/nntpcache/Makefile b/news/nntpcache/Makefile
index 5c93ff712122..a1c50d1888ac 100644
--- a/news/nntpcache/Makefile
+++ b/news/nntpcache/Makefile
@@ -28,7 +28,7 @@ SHEBANG_FILES= contrib/perlnewshound/newshound.pl
AUTHINFO_EXT= authinfo_pam.ext
USE_RC_SUBR= nntpcached
-OPTIONS_DEFINE= LDAP RADIUS SPAMPHOBIA
+OPTIONS_DEFINE= LDAP RADIUS SPAMPHOBIA DOCS
SPAMPHOBIA_DESC= Spamphobia NoCeM support
RADIUS_CONFIGURE_WITH= authinfo-radius
@@ -51,11 +51,10 @@ SPAMPHOBIA_PATCH_SITES= http://people.freebsd.org/~leeym/:SPAMPHOBIA
SPAMPHOBIA_PATCHFILES= ${DISTNAME}-spamphobia-${REVISEDATE}.diff.gz:SPAMPHOBIA
post-configure:
- ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} -C ${WRKSRC}/src ${AUTHINFO_EXT}
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} -C ${WRKSRC}/src ${AUTHINFO_EXT}
-post-install:
- @ ${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC} && ${FIND} ${PORTDOCS} \
- | ${CPIO_CMD} ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DOCSDIR})
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>