aboutsummaryrefslogtreecommitdiffstats
path: root/news/pan2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'news/pan2/Makefile')
-rw-r--r--news/pan2/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/news/pan2/Makefile b/news/pan2/Makefile
index 8f8b60012ea3..d81da1f64264 100644
--- a/news/pan2/Makefile
+++ b/news/pan2/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= pan2
-PORTVERSION= 0.14.0.91
+PORTVERSION= 0.14.0.92
CATEGORIES= news gnome
MASTER_SITES= http://pan.rebelbase.com/download/releases/${PORTVERSION}/SOURCE/ \
- http://pan.rebelbase.com/download/obsolete/${PORTVERSION}/SOURCE/ \
- ${MASTER_SITE_GNOME}
+ http://pan.rebelbase.com/download/obsolete/${PORTVERSION}/SOURCE/
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/0.14
DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -19,7 +18,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Threaded GNOME 2 newsreader based on Agent for Windows
LIB_DEPENDS= gtkspell.0:${PORTSDIR}/textproc/gtkspell2 \
- gnet-glib2.7:${PORTSDIR}/net/gnet-glib2
+ gnet-2.0.0:${PORTSDIR}/net/gnet2
USE_BZIP2= yes
USE_X_PREFIX= yes
@@ -30,10 +29,4 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib -lgnuregex -lcompat"
CONFIGURE_ARGS= --enable-html
-post-patch:
- @${REINPLACE_CMD} -e 's|gnet-config|gnet-glib2-config|g ; \
- s|gnet/gnet\.h|gnet-glib2/gnet.h|g' ${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name "*.[ch]" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|gnet/gnet\.h|gnet-glib2/gnet.h|g; s|<regex.h>|<gnuregex.h>|'
-
.include <bsd.port.mk>