aboutsummaryrefslogtreecommitdiffstats
path: root/news/sabnzbdplus/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'news/sabnzbdplus/Makefile')
-rw-r--r--news/sabnzbdplus/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/news/sabnzbdplus/Makefile b/news/sabnzbdplus/Makefile
index 665772019600..9807bac14913 100644
--- a/news/sabnzbdplus/Makefile
+++ b/news/sabnzbdplus/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= SABnzbd
-PORTVERSION= 0.1.8.1
+PORTVERSION= 0.2.2
CATEGORIES= news
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sabnzbd
@@ -27,7 +27,8 @@ PLIST_SUB= PORTNAME=${PORTNAME}
SUB_FILES= pkg-message
OPTIONS= PAR2CMDLINE "Required for postprocessing of par files." on \
- UNRAR "Often required for unpacking many downloads." on
+ UNRAR "Often required for unpacking many downloads." on \
+ FEEDPARSER "rss-feed support." on
.include <bsd.port.pre.mk>
@@ -35,6 +36,10 @@ OPTIONS= PAR2CMDLINE "Required for postprocessing of par files." on \
RUN_DEPENDS+= par2repair:${PORTSDIR}/archivers/par2cmdline
.endif
+.if !defined(WITHOUT_FEEDPARSER)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/feedparser.py:${PORTSDIR}/textproc/py-feedparser
+.endif
+
.if !defined(WITHOUT_UNRAR)
RUN_DEPENDS+= unrar:${PORTSDIR}/archivers/unrar
.endif