aboutsummaryrefslogtreecommitdiffstats
path: root/palm/palmpower/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'palm/palmpower/Makefile')
-rw-r--r--palm/palmpower/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/palm/palmpower/Makefile b/palm/palmpower/Makefile
index e00a82481db8..2c5e2069bab0 100644
--- a/palm/palmpower/Makefile
+++ b/palm/palmpower/Makefile
@@ -8,7 +8,13 @@
PORTNAME= palmpower
PORTVERSION= 1.0.2
CATEGORIES= palm
-MASTER_SITES= http://www.fh-wilhelmshaven.de/~akcaagaa/palmpower/files/
+#
+# The original MASTER_SITE has disappeared:
+# http://www.fh-wilhelmshaven.de/~akcaagaa/palmpower/files/
+# It can be downloaded via
+# http://mxlab.com/files/palm/devel/
+# but that site doesn't allow direct HTTP transfers.
+#
MAINTAINER= roman@xpert.com
@@ -17,6 +23,12 @@ USE_GMAKE= yes
MAN1= pilotdis.1
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DISTNAME}.${EXTRACT_SUFX})
+BROKEN= "Please fetch http://mxlab.com/files/palm/devel/palmpower-1.0.2.tar.gz manually and store it in ${DISTDIR}"
+.endif
+
post-build:
cd ${WRKSRC}/utils; ${CC} ${CFLAGS} -o splitprc splitprc.c
@@ -26,4 +38,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/utils/splitprc ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/man/pilotdis.1 ${PREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>