aboutsummaryrefslogtreecommitdiffstats
path: root/polish
diff options
context:
space:
mode:
Diffstat (limited to 'polish')
-rw-r--r--polish/tleenx2/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/polish/tleenx2/Makefile b/polish/tleenx2/Makefile
index 0d2a4da0057a..36d8f53c60a5 100644
--- a/polish/tleenx2/Makefile
+++ b/polish/tleenx2/Makefile
@@ -24,7 +24,10 @@ WRKSRC= ${WRKDIR}/TleenX2-${PORTVERSION}
PORTDOCS= README gg.txt sms.txt
post-patch:
- @${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},g' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} \
+ -e '/^tleenx2_LDADD =/,+1s,/usr/X11R6/lib/libXss.a,-lXss,' \
+ -e 's,/usr/X11R6/lib/libXss.a,,' \
+ ${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} 's,/usr/local,${LOCALBASE},g; s,gcc,${CC},' \
${WRKSRC}/iksemel/Makefile
@${REINPLACE_CMD} 's,gcc,${CC},' ${WRKSRC}/jabby/Makefile