aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/portmaster/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt/portmaster/Makefile')
-rw-r--r--ports-mgmt/portmaster/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/ports-mgmt/portmaster/Makefile b/ports-mgmt/portmaster/Makefile
new file mode 100644
index 000000000000..d76a2f4c4914
--- /dev/null
+++ b/ports-mgmt/portmaster/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: portmaster
+# Date created: 20 February 2006
+# Whom: Doug Barton <dougb@FreeBSD.org>
+#
+# $FreeBSD$
+#
+# This port is self contained in the files directory.
+#
+
+PORTNAME= portmaster
+PORTVERSION= 1.1
+CATEGORIES= sysutils
+MASTER_SITES= # none
+DISTFILES= # none
+
+MAINTAINER= dougb@FreeBSD.org
+COMMENT= Manage your ports without external databases or languages
+
+NO_BUILD= yes
+SUB_FILES= portmaster.sh
+
+PLIST_FILES= sbin/portmaster
+
+MAN8= portmaster.8
+
+do-fetch:
+ @${DO_NADA}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/portmaster.sh ${PREFIX}/sbin/portmaster
+ ${INSTALL_MAN} ${FILESDIR}/portmaster.8 ${MAN8PREFIX}/man/man8
+
+.include <bsd.port.mk>