aboutsummaryrefslogtreecommitdiffstats
path: root/print/cups-base/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/cups-base/Makefile')
-rw-r--r--print/cups-base/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 8c92934970ed..1e3552b1aedb 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cups
PORTVERSION= 1.2.11
+PORTREVISION= 1
DISTVERSIONSUFFIX= -source
CATEGORIES= print
MASTER_SITES= EASYSW/${PORTNAME}/${DISTVERSION}
@@ -59,6 +60,12 @@ CUPSSYSGRP= wheel
.include <bsd.port.pre.mk>
+.if defined(CUPS_OVERWRITE_BASE)
+PLIST_SUB+= OVERWRITE=""
+.else
+PLIST_SUB+= OVERWRITE="@comment "
+.endif
+
.if !defined(WITHOUT_GNUTLS)
CONFIGURE_ARGS+= --enable-gnutls --disable-openssl
LIB_DEPENDS+= gnutls-openssl.15:${PORTSDIR}/security/gnutls
@@ -146,14 +153,16 @@ pre-install:
if ! pw groupshow ${CUPSGRP}; then pw groupadd ${CUPSGRP} -g 193; fi
if ! pw usershow ${CUPSOWN}; then pw useradd ${CUPSOWN} -g ${CUPSGRP} -u 193 \
-h - -d ${NONEXISTENT} -s /usr/sbin/nologin -c "CUPS Owner"; fi
+.if defined(CUPS_OVERWRITE_BASE)
+ if test -e /usr/bin/lp; then chmod -h 0 /usr/bin/lp; fi
+ if test -e /usr/bin/lpq; then chmod -h 0 /usr/bin/lpq; fi
+ if test -e /usr/bin/lpr; then chmod -h 0 /usr/bin/lpr; fi
+ if test -e /usr/bin/lprm; then chmod -h 0 /usr/bin/lprm; fi
+ if test -e /usr/sbin/lpc; then chmod -h 0 /usr/sbin/lpc; fi
+.endif
post-install:
${INSTALL} -d ${CUPS_ETCDIR}/
-.if defined(CUPS_OVERWRITE_BASE)
- ${SH} ${PKGINSTALL} placeholder POST-INSTALL overwrite
-.else
- ${SH} ${PKGINSTALL} placeholder POST-INSTALL
-.endif
.for f in cupsd.conf mime.convs mime.types
${INSTALL_DATA} ${WRKSRC}/conf/${f} ${CUPS_ETCDIR}/${f}.N
cd ${CUPS_ETCDIR}/; if test ! -f ${f}; then ${CP} -p ${f}.N ${f}; fi