aboutsummaryrefslogtreecommitdiffstats
path: root/print/cups/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/cups/Makefile')
-rw-r--r--print/cups/Makefile121
1 files changed, 121 insertions, 0 deletions
diff --git a/print/cups/Makefile b/print/cups/Makefile
new file mode 100644
index 000000000000..978b5c69564b
--- /dev/null
+++ b/print/cups/Makefile
@@ -0,0 +1,121 @@
+# Created by: Alan Eldridge <alane@geeksrus.net>
+# $FreeBSD$
+
+PORTNAME= cups
+PORTVERSION= 2.1.3
+DISTVERSIONSUFFIX=-source
+CATEGORIES= print
+MASTER_SITES= http://www.cups.org/software/${PORTVERSION}/
+
+MAINTAINER= tijl@FreeBSD.org
+COMMENT= Common UNIX Printing System
+
+LICENSE= GPLv2 LGPL20
+LICENSE_COMB= multi
+LICENSE_FILE_GPLv2= ${WRKSRC}/LICENSE.txt
+LICENSE_FILE_LGPL20= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
+
+CONFLICTS= LPRng-[0-9]*
+
+DESTDIRNAME= DSTROOT
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-dnssd \
+ --disable-gssapi \
+ --disable-launchd \
+ --disable-systemd \
+ --enable-gnutls \
+ --with-cups-user=${USERS} \
+ --with-cups-group=${GROUPS} \
+ --with-system-groups=wheel \
+ --with-dbusdir="${PREFIX}/etc/dbus-1" \
+ --with-icondir="${PREFIX}/share/icons" \
+ --with-menudir="${DESKTOPDIR}" \
+ --with-printcap="${PREFIX}/etc/printcap" \
+ --with-rcdir=no \
+ --with-optim=" " \
+ --with-pam-module="unix" \
+ ac_cv_path_JAVA= ac_cv_path_PERL= ac_cv_path_PHPCGI= \
+ ac_cv_path_PHP= ac_cv_path_PYTHON=
+LIBS+= -L${LOCALBASE}/lib
+USES= cpe gmake iconv pkgconfig tar:bzip2
+CPE_VENDOR= apple
+USE_LDCONFIG= yes
+USE_RC_SUBR= cupsd
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+GROUPS= cups
+USERS= cups
+
+OPTIONS_DEFINE= AVAHI DBUS DOCS IPPTOOL LIBPAPER NLS X11
+OPTIONS_DEFAULT= AVAHI DBUS LIBPAPER
+OPTIONS_SUB= yes
+
+AVAHI_LIB_DEPENDS= libavahi-client.so:${PORTSDIR}/net/avahi-app
+AVAHI_CONFIGURE_ENABLE= avahi
+AVAHI_SUB_LIST= AVAHI_DAEMON=avahi_daemon
+AVAHI_SUB_LIST_OFF= AVAHI_DAEMON=
+
+DBUS_LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus
+DBUS_CONFIGURE_ENABLE= dbus
+DBUS_SUB_LIST= DBUS_DAEMON=dbus
+DBUS_SUB_LIST_OFF= DBUS_DAEMON=
+
+IPPTOOL_DESC= Internet Printing Protocol testing tool
+
+LIBPAPER_LIB_DEPENDS= libpaper.so:${PORTSDIR}/print/libpaper
+LIBPAPER_CONFIGURE_ENABLE=libpaper
+
+X11_DESC= Install desktop menu item
+X11_BUILD_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
+X11_RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
+
+.if defined(CUPS_OVERWRITE_BASE)
+PLIST_SUB+= OVERWRITE=""
+.else
+PLIST_SUB+= OVERWRITE="@comment "
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if empty(ICONV_LIB)
+CONFIGURE_ARGS+=ac_cv_search_libiconv_open=no
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e '/SILENT/d' ${WRKSRC}/Makedefs.in
+ @${REINPLACE_CMD} -e 's|/private/etc/pam.d|${LOCALBASE}/etc/pam.d|' \
+ -e 's/-fstack-protector//' ${WRKSRC}/configure
+ @${REINPLACE_CMD} 's|http://www.cups.org|https://cups.org|' \
+ ${WRKSRC}/doc/index.html.in \
+ ${WRKSRC}/doc/??/index.html.in \
+ ${WRKSRC}/templates/header.tmpl.in \
+ ${WRKSRC}/templates/??/header.tmpl.in \
+ ${WRKSRC}/templates/help-header.tmpl \
+ ${WRKSRC}/templates/??/help-header.tmpl
+ @${REINPLACE_CMD} '/stripopt=/s/-x//' ${WRKSRC}/install-sh
+ @${REINPLACE_CMD} 's|/etc/cups|${LOCALBASE}/etc/cups|g' \
+ ${WRKSRC}/man/*.man*
+ @${REINPLACE_CMD} -e 's|\.default|.sample|'\
+ ${WRKSRC}/cgi-bin/admin.c\
+ ${WRKSRC}/conf/Makefile
+
+post-patch-DOCS-off:
+# Link to online documentation.
+ @${REINPLACE_CMD} \
+ 's|"/*help/|"https://cups.org/documentation.php/doc-${PORTVERSION:R}/|' \
+ ${WRKSRC}/doc/index.html.in \
+ ${WRKSRC}/doc/??/index.html.in \
+ ${WRKSRC}/templates/choose-uri.tmpl \
+ ${WRKSRC}/templates/??/choose-uri.tmpl \
+ ${WRKSRC}/templates/header.tmpl.in \
+ ${WRKSRC}/templates/??/header.tmpl.in \
+ ${WRKSRC}/templates/samba-export.tmpl \
+ ${WRKSRC}/templates/??/samba-export.tmpl
+
+post-install:
+ ${LN} -sf lpr ${STAGEDIR}${PREFIX}/bin/lpr-cups
+ ${INSTALL_DATA} ${FILESDIR}/cups ${STAGEDIR}${PREFIX}/etc/pam.d
+
+.include <bsd.port.post.mk>