aboutsummaryrefslogtreecommitdiffstats
path: root/print/ghostscript-gpl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/ghostscript-gpl/Makefile')
-rw-r--r--print/ghostscript-gpl/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/print/ghostscript-gpl/Makefile b/print/ghostscript-gpl/Makefile
index 5515938a93d2..9d58bf146a5c 100644
--- a/print/ghostscript-gpl/Makefile
+++ b/print/ghostscript-gpl/Makefile
@@ -54,6 +54,7 @@ NO_CDROM= "Can only be distributed for free"
WRKSRC= ${WRKDIR}/gs${PORTVERSION}
+USE_REINPLACE= yes
USE_BZIP2= yes
USE_GMAKE= yes
MAKE_ENV= CC="${CC}" CXX="${CXX}" CFLAGS_STANDARD="${CFLAGS}" \
@@ -284,14 +285,14 @@ post-extract:
${TAR} -C ${WRKSRC}/src -xzf ${DISTDIR}/${DIST_SUBDIR}/${GDI_SRCS}
post-patch:
- ${PERL} -pi -e 's|^DEVICE_DEVS|#DEVICE_DEVS|g' \
+ ${REINPLACE_CMD} -e 's|^DEVICE_DEVS|#DEVICE_DEVS|g' \
${WRKSRC}/src/unix-gcc.mak
- ${PERL} -pi -e 's|\. de|\.|g' \
+ ${REINPLACE_CMD} -e 's|\. de|\.|g' \
${WRKSRC}/src/unixinst.mak
- ${PERL} -pi -e 's|%%DATADIR%%|${DATADIR}|g' \
+ ${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|g' \
${WRKSRC}/lib/gs_res.ps
# for DMPRT driver
- ${PERL} -pi -e 's|%%DATADIR%%|${DATADIR}|g ; \
+ ${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|g ; \
s|%%GS_VERSION%%|${PORTVERSION}|g' \
${WRKSRC}/src/dmp_site.ps