aboutsummaryrefslogtreecommitdiffstats
path: root/print/gutenprint-base/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/gutenprint-base/Makefile')
-rw-r--r--print/gutenprint-base/Makefile47
1 files changed, 19 insertions, 28 deletions
diff --git a/print/gutenprint-base/Makefile b/print/gutenprint-base/Makefile
index 646dbf9bb185..6b50001e3563 100644
--- a/print/gutenprint-base/Makefile
+++ b/print/gutenprint-base/Makefile
@@ -1,43 +1,46 @@
# ports collection makefile for: gimp-print
# Date Created: 2002 01 02
# Whom: dgilbert@velocet.ca
-
+#
# $FreeBSD$
+# $MCom: ports/print/gutenprint/Makefile,v 1.3 2006/02/25 00:13:44 marcus Exp $
-PORTNAME= gimp-print
-PORTVERSION= 4.2.7
-PORTREVISION= 2
+PORTNAME= gutenprint
+DISTVERSION= 5.0.0-rc3
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITE_SUBDIR= gimp-print
+
+MAINTAINER= ahze@FreeBSD.org
+COMMENT= GutenPrint Printer Driver
-MAINTAINER= ports@FreeBSD.org
-COMMENT= GIMP Print Printer Driver
+CONFLICTS= gimp-print-[0-9]*
+USE_BZIP2= yes
USE_GETTEXT= yes
USE_GETOPT_LONG= yes
USE_GMAKE= yes
+USE_GNOME= gnomehack gnometarget gtk20
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --with-gimp=no
+CONFIGURE_ARGS= --with-gimp=no --with-gimp2=no \
+ --without-foomatic
INSTALLS_SHLIB= yes
-MAN1= escputil.1 gimpprint-config.1 ijsgimpprint.1
-MAN3= gimpprint.3
-MAN7= gimpprint-color.7 gimpprint-dithers.7 gimpprint-imagetypes.7 \
- gimpprint-inktypes.7 gimpprint-mediasizes.7 gimpprint-mediasources.7 \
- gimpprint-mediatypes.7 gimpprint-models.7 gimpprint-resolutions.7
-MAN8= cups-calibrate.8
-INFO= gimpprint
+MAN1= escputil.1 ijsgutenprint.1
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
+.include <bsd.port.pre.mk>
+
.if defined(WITH_CUPS) && !defined(WITHOUT_CUPS)
LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
RUN_DEPENDS+= espgs:${PORTSDIR}/print/cups-pstoraster
CONFIGURE_ARGS+= --with-cups=${PREFIX}
PLIST_SUB+= CUPS=""
+MAN8= cups-calibrate.8 cups-genppd.8 cups-genppdconfig.8 \
+ cups-genppdupdate.8
.else
PLIST_SUB+= CUPS="@comment "
CONFIGURE_ARGS+= --without-cups
@@ -63,16 +66,4 @@ pre-everything::
@${ECHO_MSG} " WITHOUT_IJS=yes build without IJS-based Ghostscript driver"
@${ECHO_MSG}
-post-extract:
- @${RM} -f ${WRKSRC}/doc/gimpprint.info*
-
-post-patch:
- @${REINPLACE_CMD} -e 's|=makeinfo|="makeinfo --no-split"|g ; \
- s|$${CFLAGS:=} -O|$${CFLAGS}|g' ${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|$$(PACKAGE)/doc|doc/$$(PACKAGE)|g ; \
- s|LANGUAGE=|LANG=|g ; \
- s|: install-gimp_plug_inPROGRAMS|:|g ; \
- s|$$(RM) -r|$$(RM) -f -r|g'
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>