aboutsummaryrefslogtreecommitdiffstats
path: root/print/photoprint/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/photoprint/Makefile')
-rw-r--r--print/photoprint/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/print/photoprint/Makefile b/print/photoprint/Makefile
index 8f0137fffc88..42182bd29735 100644
--- a/print/photoprint/Makefile
+++ b/print/photoprint/Makefile
@@ -4,11 +4,12 @@ PORTNAME= photoprint
DISTVERSION= 0.4.2-pre2
CATEGORIES= print graphics
MASTER_SITES= http://www.blackfiveimaging.co.uk/photoprint/
-#DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= bsam@FreeBSD.org
COMMENT= Utility to print multiple images per sheet
+LICENCE= GPLv2
+
LIB_DEPENDS= cups:${PORTSDIR}/print/cups-client \
expat:${PORTSDIR}/textproc/expat2 \
gdk_pixbuf-2.0:${PORTSDIR}/graphics/gdk-pixbuf2 \
@@ -16,22 +17,20 @@ LIB_DEPENDS= cups:${PORTSDIR}/print/cups-client \
lcms:${PORTSDIR}/graphics/lcms \
netpbm:${PORTSDIR}/graphics/netpbm \
pcre:${PORTSDIR}/devel/pcre \
- pcre:${PORTSDIR}/devel/pcre \
pixman:${PORTSDIR}/x11/pixman \
png15:${PORTSDIR}/graphics/png \
pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
tiff:${PORTSDIR}/graphics/tiff \
xcb:${PORTSDIR}/x11/libxcb
-LICENCE= GPLv2
-
+GNU_CONFIGURE= yes
USE_GETTEXT= yes
-HAS_CONFIGURE= yes
-INSTALLS_ICONS= yes
-CONFIGURE_ARGS+=LDFLAGS=-L/usr/local/lib
USE_GNOME= desktopfileutils pango
USE_XORG= x11 xau xcomposite xcursor xdamage xdmcp xext \
xfixes xi xinerama xrandr xrender
+INSTALLS_ICONS= yes
+
+LDFLAGS+= -L${LOCALBASE}/lib
post-install:
-@update-desktop-database