aboutsummaryrefslogtreecommitdiffstats
path: root/print/qpdfview
diff options
context:
space:
mode:
Diffstat (limited to 'print/qpdfview')
-rw-r--r--print/qpdfview/Makefile33
-rw-r--r--print/qpdfview/distinfo2
-rw-r--r--print/qpdfview/pkg-descr3
-rw-r--r--print/qpdfview/pkg-plist34
4 files changed, 72 insertions, 0 deletions
diff --git a/print/qpdfview/Makefile b/print/qpdfview/Makefile
new file mode 100644
index 000000000000..bfc8772923d4
--- /dev/null
+++ b/print/qpdfview/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: qpdfview
+# Date created: 2012-07-10
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qpdfview
+PORTVERSION= 0.3.1
+CATEGORIES= print
+MASTER_SITES= https://launchpadlibrarian.net/109087731/
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Tabbed PDF viewer using the poppler library
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= poppler-qt4:${PORTSDIR}/graphics/poppler-qt4 \
+ cups:${PORTSDIR}/print/cups-client
+
+USE_QT_VER= 4
+QT_COMPONENTS= corelib dbus gui moc qmake_build svg xml
+
+MAN1= ${PORTNAME}.1
+
+.include <bsd.port.pre.mk>
+pre-configure:
+ ${REINPLACE_CMD} -e 's#/usr#${PREFIX}#g;s#${PREFIX}/share/man#${PREFIX}/man#g' \
+ ${WRKSRC}/${PORTNAME}.pri
+
+do-configure:
+ cd ${WRKSRC} && ${QMAKE} ${QMAKEFLAGS}
+.include <bsd.port.post.mk>
diff --git a/print/qpdfview/distinfo b/print/qpdfview/distinfo
new file mode 100644
index 000000000000..d0b848c51204
--- /dev/null
+++ b/print/qpdfview/distinfo
@@ -0,0 +1,2 @@
+SHA256 (qpdfview-0.3.1.tar.gz) = 1eb1c6c2eb80f4a37f137983fce83bb640aa47bbc3b8a69e3ddd8d917f016b57
+SIZE (qpdfview-0.3.1.tar.gz) = 76652
diff --git a/print/qpdfview/pkg-descr b/print/qpdfview/pkg-descr
new file mode 100644
index 000000000000..25e6b1f2aa5b
--- /dev/null
+++ b/print/qpdfview/pkg-descr
@@ -0,0 +1,3 @@
+qpdfview is a tabbed PDF viewer using the poppler library.
+
+WWW: https://launchpad.net/qpdfview
diff --git a/print/qpdfview/pkg-plist b/print/qpdfview/pkg-plist
new file mode 100644
index 000000000000..f8cafa7433fd
--- /dev/null
+++ b/print/qpdfview/pkg-plist
@@ -0,0 +1,34 @@
+bin/qpdfview
+share/applications/qpdfview.desktop
+%%DATADIR%%/go-first.svg
+%%DATADIR%%/x-office-presentation.svg
+%%DATADIR%%/do-not-scale.svg
+%%DATADIR%%/tab-new.svg
+%%DATADIR%%/document-save.svg
+%%DATADIR%%/go-down.svg
+%%DATADIR%%/zoom-in.svg
+%%DATADIR%%/document-print.svg
+%%DATADIR%%/object-rotate-left.svg
+%%DATADIR%%/one-page.svg
+%%DATADIR%%/go-jump.svg
+%%DATADIR%%/fit-to-page-width.svg
+%%DATADIR%%/object-rotate-right.svg
+%%DATADIR%%/fit-to-page.svg
+%%DATADIR%%/edit-find.svg
+%%DATADIR%%/two-columns.svg
+%%DATADIR%%/go-next.svg
+%%DATADIR%%/two-pages.svg
+%%DATADIR%%/one-column.svg
+%%DATADIR%%/document-open.svg
+%%DATADIR%%/go-last.svg
+%%DATADIR%%/process-stop.svg
+%%DATADIR%%/qpdfview_de.qm
+%%DATADIR%%/zoom-out.svg
+%%DATADIR%%/go-up.svg
+%%DATADIR%%/go-previous.svg
+%%DATADIR%%/view-fullscreen.svg
+%%DATADIR%%/help.html
+%%DATADIR%%/qpdfview.svg
+%%DATADIR%%/view-refresh.svg
+@dirrmtry share/applications
+@dirrm %%DATADIR%%