aboutsummaryrefslogtreecommitdiffstats
path: root/print/rubygem-prawn-templates/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/rubygem-prawn-templates/Makefile')
-rw-r--r--print/rubygem-prawn-templates/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/print/rubygem-prawn-templates/Makefile b/print/rubygem-prawn-templates/Makefile
new file mode 100644
index 000000000000..3ce572bd19bc
--- /dev/null
+++ b/print/rubygem-prawn-templates/Makefile
@@ -0,0 +1,25 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= prawn-templates
+PORTVERSION= 0.1.2
+CATEGORIES= print rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Include other pdfs or combine several pdf documents into one
+
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
+LICENSE_FILE_GPLv2= ${WRKSRC}/GPLv2
+LICENSE_FILE_GPLv3= ${WRKSRC}/GPLv3
+
+RUN_DEPENDS= rubygem-pdf-reader>=2.0<3:print/rubygem-pdf-reader \
+ rubygem-prawn>=2.2<3:print/rubygem-prawn
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>