aboutsummaryrefslogtreecommitdiffstats
path: root/print/scribus-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/scribus-devel/Makefile')
-rw-r--r--print/scribus-devel/Makefile53
1 files changed, 16 insertions, 37 deletions
diff --git a/print/scribus-devel/Makefile b/print/scribus-devel/Makefile
index 7dc38e1d7f4a..e27982d51aab 100644
--- a/print/scribus-devel/Makefile
+++ b/print/scribus-devel/Makefile
@@ -6,47 +6,26 @@
# $FreeBSD$
#
-PORTNAME= scribus
-PORTVERSION= 0.9.1
-PORTREVISION= 0
-CATEGORIES= print editors
-MASTER_SITES= http://web2.altmuehlnet.de/fschmid/
-DIST_SUBDIR= ${PORTNAME}
-#PATCH_SITES= ${MASTER_SITES}
-#PATCHFILES=
-#PATCH_DIST_STRIP= -p1
+PORTNAME= scribus
+PORTVERSION= 0.9.6
+CATEGORIES= print editors
+MASTER_SITES= http://web2.altmuehlnet.de/fschmid/
+DIST_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@freebsd.org
+MAINTAINER= ports@FreeBSD.org
-RUN_DEPENDS+= gs:${PORTSDIR}/print/ghostscript-gnu
-
-BROKEN= "crashes on startup"
-
-USE_QT_VER= 3
-USE_REINPLACE= yes
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
+LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-base
+RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu
+USE_QT_VER= 3
+USE_REINPLACE= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-LDCONFIG_DIRS= %%PREFIX%%/share/scribus/libs \
- %%PREFIX%%/share/scribus/plugins
-
-QTCFGLIBS+= -lm
-
-post-patch::
- ${FIND} ${WRKSRC} -type f \
- |${XARGS} ${GREP} -l 'share/scribus/doc'\
- |${XARGS} -n 1 ${REINPLACE_CMD} \
- -e 's|share/scribus/doc|share/doc/scribus|'
-
-.if defined(NOPORTDOCS)
-post-patch::
- ${REINPLACE_CMD} -e "s|docs icons|icons|" \
- ${WRKSRC}/scribus/Makefile.in
-.endif # defined(NOPORTDOCS)
+LDCONFIG_DIRS= %%PREFIX%%/lib/scribus/libs \
+ %%PREFIX%%/lib/scribus/plugins
-#post-configure::
-# ${FIND} ${WRKSRC} -name Makefile \
-# |${XARGS} -n 1 ${REINPLACE_CMD} -e 's|-O2||g'
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
.include <bsd.port.mk>