aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
Diffstat (limited to 'print')
-rw-r--r--print/freetype-tools/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/print/freetype-tools/Makefile b/print/freetype-tools/Makefile
index 846ad2290406..4510c455ea00 100644
--- a/print/freetype-tools/Makefile
+++ b/print/freetype-tools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= freetype-tools
PORTVERSION= 1.3.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S,%SUBDIR%,freetype,} \
http://sunsite.cnlab-switch.ch/ftp/mirror/freetype/%SUBDIR%/ \
@@ -22,14 +22,14 @@ MAINTAINER= rafan@FreeBSD.org
COMMENT= Tools for FreeType 1
LIB_DEPENDS= ttf.4:${PORTSDIR}/print/freetype
-BUILD_DEPENDS= ${LOCALBASE}/lib/libkpathsea.a:${PORTSDIR}/print/teTeX-base
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${LOCALBASE}/lib/libkpathsea.a:${PORTSDIR}/print/teTeX-base
+BUILD_DEPENDS= ${RUN_DEPENDS}
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --disable-nls --enable-static --enable-shared
-TEXMFMAIN= ${PREFIX}/share/texmf
+TEXMFMAIN= ${TARGETDIR}/share/texmf
MAN1= ttf2bdf.1 ttf2tfm.1 ttf2pk.1
@@ -38,13 +38,13 @@ post-patch:
${WRKSRC}/configure
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|LIBTOOL =.*|LIBTOOL = ${LIBTOOL}|'
- @${FIND} ${WRKSRC} -name '*.orig' | ${XARGS} ${RM}
+ @${FIND} ${WRKSRC} -name '*.orig' -delete
post-build:
- @cd ${WRKSRC}/contrib/ttf2bdf && ./configure --prefix=${PREFIX} && ${GMAKE}
- @cd ${WRKSRC}/contrib/ttf2pfb && ./configure --prefix=${PREFIX} && ${GMAKE}
- @cd ${WRKSRC}/contrib/ttf2pk && ./configure --prefix=${PREFIX} --with-kpathsea-dir=${LOCALBASE} && ${GMAKE}
- @cd ${WRKSRC}/contrib/ttfbanner && ./configure --prefix=${PREFIX} && ${GMAKE}
+ @cd ${WRKSRC}/contrib/ttf2bdf && ./configure --prefix=${TARGETDIR} && ${GMAKE}
+ @cd ${WRKSRC}/contrib/ttf2pfb && ./configure --prefix=${TARGETDIR} && ${GMAKE}
+ @cd ${WRKSRC}/contrib/ttf2pk && ./configure --prefix=${TARGETDIR} --with-kpathsea-dir=${LOCALBASE} && ${GMAKE}
+ @cd ${WRKSRC}/contrib/ttfbanner && ./configure --prefix=${TARGETDIR} && ${GMAKE}
do-install:
@cd ${WRKSRC}/contrib/ttf2bdf && ${GMAKE} install
tions'>-5/+3 * Fix runtime error with wrong datadir.vanilla2015-02-262-0/+16 * Fix build on 10 (makeinfo issue)vanilla2015-02-152-5/+23 * 1: Upgrade to 0.4.0.vanilla2015-02-097-53/+37 * Finish resetting maintainershipbapt2014-12-031-1/+1 * Cleanup plistbapt2014-10-201-2/+0 * - Switch to USES=libtool, drop .la filesamdmi32014-06-192-2/+3 * - USE_(BZIP2|XZ) -> USES=tar:(bzip2|xz)ohauer2014-06-021-2/+1 * Support STAGEDIR.vanilla2014-01-082-4/+2 * Add NO_STAGE all over the place in preparation for the staging support (cat: ...bapt2013-09-211-0/+1 * Convert remanent USE_PKGCONFIG to USES=pkgconfigbapt2013-07-061-3/+1 * Update chinese/libchewing to 0.3.4clsung2013-06-275-10/+47 * Fails to install on powerpc: signal 6.linimon2011-11-111-1/+7 * - Remove WITH_FBSD10_FIX, is no longer neededmiwi2011-11-091-1/+0 * Fix build with FreeBSD 10kwm2011-10-301-0/+1 * Remove more tags from pkg-descr files fo the form:dougb2011-10-241-3/+0 * - Update to 0.3.3clsung2011-03-032-4/+3 * - Update to 0.3.2clsung2009-12-186-45/+9 * - Remove USE_GCC where it can be satisfied with base compiler on followingpav2008-07-251-1/+0 * - Remove the DESTDIR modifications from individual ports as we have a new,gabor2007-08-041-1/+1 * - Respect DESTDIRclsung2006-08-141-2/+2 * - Require newer GCC to build, fix build on 4.xclsung2006-05-221-0/+1 * - since isspace(0xa0) return true. When using sscanf(...,"%s",...),clsung2006-05-213-0/+23 * - update to 0.3.0clsung2006-05-164-40/+9 * - Fix build on 4.x. Dont use C99 syntax.clsung2006-04-271-0/+32 * Conversion to a single libtool environment.ade2006-02-232-1/+3 * - Update to 0.2.7clsung2006-02-063-8/+15 * SHA256ify (manually done and checked)edwin2006-01-221-0/+1 * BROKEN: Does not buildkris2006-01-141-0/+2 * Mass-conversion to the USE_AUTOTOOLS New World Order. The code presentade2005-11-151-1/+1 * - update the URL of master siteleeym2005-03-064-15/+16