aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
Diffstat (limited to 'print')
-rw-r--r--print/cups-filters/Makefile4
-rw-r--r--print/cups-filters/distinfo4
-rw-r--r--print/cups-filters/files/patch-filter_pdftops.c6
-rw-r--r--print/cups-filters/files/patch-poppler-0.3448
-rw-r--r--print/cups-filters/pkg-plist1
5 files changed, 7 insertions, 56 deletions
diff --git a/print/cups-filters/Makefile b/print/cups-filters/Makefile
index 78fe3c092ea2..81f93bfaad3e 100644
--- a/print/cups-filters/Makefile
+++ b/print/cups-filters/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= cups-filters
-PORTVERSION= 1.0.71
-PORTREVISION= 2
+PORTVERSION= 1.0.76
CATEGORIES= print
MASTER_SITES= http://www.openprinting.org/download/cups-filters/
@@ -23,7 +22,6 @@ LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
libpoppler.so:${PORTSDIR}/graphics/poppler
-MAKE_JOBS_UNSAFE=YES
USES= compiler:c++11-lib cpe ghostscript jpeg libtool pathfix \
pkgconfig shebangfix tar:xz
CPE_VENDOR= linuxfoundation
diff --git a/print/cups-filters/distinfo b/print/cups-filters/distinfo
index 49b1b5967aab..5992934ed740 100644
--- a/print/cups-filters/distinfo
+++ b/print/cups-filters/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cups-filters-1.0.71.tar.xz) = 3180aa209c383402822e568ccef8e1ca43f51e30b3af2039c34ebae919a69c1f
-SIZE (cups-filters-1.0.71.tar.xz) = 1339116
+SHA256 (cups-filters-1.0.76.tar.xz) = b3a190b11a102af6994e41d2cfa47e5caf999c7d046f3c0b940f6b38729f5b32
+SIZE (cups-filters-1.0.76.tar.xz) = 1353016
diff --git a/print/cups-filters/files/patch-filter_pdftops.c b/print/cups-filters/files/patch-filter_pdftops.c
index f9974e300d2a..461664bf4a4b 100644
--- a/print/cups-filters/files/patch-filter_pdftops.c
+++ b/print/cups-filters/files/patch-filter_pdftops.c
@@ -1,6 +1,6 @@
---- filter/pdftops.c.orig 2014-08-21 10:11:24.448404905 -0400
-+++ filter/pdftops.c 2014-08-21 10:12:00.298402116 -0400
-@@ -535,7 +535,7 @@
+--- filter/pdftops.c.orig 2015-07-04 11:21:47 UTC
++++ filter/pdftops.c
+@@ -535,7 +535,7 @@ main(int argc, /* I - Number of comm
if (renderer == PDFTOPS)
{
diff --git a/print/cups-filters/files/patch-poppler-0.34 b/print/cups-filters/files/patch-poppler-0.34
deleted file mode 100644
index 6a116015657f..000000000000
--- a/print/cups-filters/files/patch-poppler-0.34
+++ /dev/null
@@ -1,48 +0,0 @@
-# http://bzr.linuxfoundation.org/loggerhead/openprinting/cups-filters/revision/7371
-
- CHANGES IN V1.0.72
-
-+ - pdftoopvp: Adaptations to API changes on Poppler 0.34.0, note that
-+ this patch disables color management in this filter. Thanks to
-+ Vincent le Garrec and Andreas K. Huettel for the patch (Bug #1301,
-+ Gentoo bug #554782).
- - libcupsfilters, bannertopdf, foomatic-rip, gstoraster, pdftoijs,
- sys5ippprinter, pdftoopvp, pdftops, pdftoraster, rastertoescpx,
- urftopdf, texttopdf: Miscellaneous fixes for build compatibility with
-
-=== modified file 'filter/pdftoopvp/OPVPOutputDev.cxx'
---- filter/pdftoopvp/OPVPOutputDev.cxx 2015-02-18 03:17:28 +0000
-+++ filter/pdftoopvp/OPVPOutputDev.cxx 2015-07-14 19:22:49 +0000
-@@ -1811,10 +1811,14 @@
- #if POPPLER_VERSION_MAJOR <= 0 && (POPPLER_VERSION_MINOR <= 20 || (POPPLER_VERSION_MINOR == 21 && POPPLER_VERSION_MICRO <= 2))
- maskSplash->drawImage(&imageSrc, &imgMaskData,
- splashModeMono8, gFalse, maskWidth, maskHeight, mat);
--#else
-+#elif POPPLER_VERSION_MAJOR <= 0 && POPPLER_VERSION_MINOR <= 33
- maskSplash->drawImage(&imageSrc, &imgMaskData,
- splashModeMono8, gFalse, maskWidth, maskHeight,
- mat,gFalse);
-+#else
-+ maskSplash->drawImage(&imageSrc, 0, &imgMaskData,
-+ splashModeMono8, gFalse, maskWidth, maskHeight,
-+ mat,gFalse);
- #endif
- delete imgMaskData.imgStr;
- maskStr->close();
-
-=== modified file 'filter/pdftoopvp/oprs/OPRS.cxx'
---- filter/pdftoopvp/oprs/OPRS.cxx 2013-01-09 10:42:32 +0000
-+++ filter/pdftoopvp/oprs/OPRS.cxx 2015-07-14 19:22:49 +0000
-@@ -240,8 +240,10 @@
- if (rasterMode) {
- #if POPPLER_VERSION_MAJOR <= 0 && (POPPLER_VERSION_MINOR <= 20 || (POPPLER_VERSION_MINOR == 21 && POPPLER_VERSION_MICRO <= 2))
- return splash->drawImage(src,srcData,srcMode,srcAlpha,w,h,mat);
--#else
-+#elif POPPLER_VERSION_MAJOR <= 0 && POPPLER_VERSION_MINOR <= 33
- return splash->drawImage(src,srcData,srcMode,srcAlpha,w,h,mat,gFalse);
-+#else
-+ return splash->drawImage(src,0,srcData,srcMode,srcAlpha,w,h,mat,gFalse);
- #endif
- } else {
- return opvpSplash->drawImage(src,srcData,srcMode,srcAlpha,w,h,mat);
-
diff --git a/print/cups-filters/pkg-plist b/print/cups-filters/pkg-plist
index 625663a483f7..d6060bd74281 100644
--- a/print/cups-filters/pkg-plist
+++ b/print/cups-filters/pkg-plist
@@ -21,6 +21,7 @@ lib/libfontembed.so.1
lib/libfontembed.so.1.0.0
libdata/pkgconfig/libcupsfilters.pc
libdata/pkgconfig/libfontembed.pc
+libexec/cups/backend/implicitclass
libexec/cups/backend/parallel
libexec/cups/backend/serial
libexec/cups/filter/bannertopdf