aboutsummaryrefslogtreecommitdiffstats
path: root/science/pulseview/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/pulseview/Makefile')
-rw-r--r--science/pulseview/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/science/pulseview/Makefile b/science/pulseview/Makefile
index 1d3ae03ad3b6..a1f59f215e7b 100644
--- a/science/pulseview/Makefile
+++ b/science/pulseview/Makefile
@@ -11,6 +11,7 @@ MAINTAINER= uffe@uffe.org
COMMENT= GUI client that supports various hardware logic analyzers
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
libsigrok.so:${PORTSDIR}/devel/libsigrok \
@@ -18,7 +19,8 @@ LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
USES= cmake gmake pkgconfig
USE_QT4= corelib gui moc_build qmake_build rcc_build uic_build
-CMAKE_ARGS+= -DCMAKE_INSTALL_MANDIR:PATH=${MANPREFIX}/man
+CMAKE_ARGS+= -DCMAKE_INSTALL_MANDIR:PATH=${MANPREFIX}/man \
+ -DDISABLE_WERROR:BOOL=TRUE
PLIST_FILES= bin/pulseview man/man1/pulseview.1.gz
MAKE_JOBS_UNSAFE=yes