aboutsummaryrefslogtreecommitdiffstats
path: root/science/silo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/silo/Makefile')
-rw-r--r--science/silo/Makefile36
1 files changed, 14 insertions, 22 deletions
diff --git a/science/silo/Makefile b/science/silo/Makefile
index 1ab765131555..a6bc89d10c9c 100644
--- a/science/silo/Makefile
+++ b/science/silo/Makefile
@@ -2,57 +2,49 @@
# $FreeBSD$
PORTNAME= silo
-PORTVERSION= 4.9.1
+PORTVERSION= 4.10
DISTVERSIONSUFFIX= -bsd
-PORTREVISION= 2
CATEGORIES= science
MASTER_SITES= https://wci.llnl.gov/codes/${PORTNAME}/silo-${PORTVERSION}/
MAINTAINER= ports@FreeBSD.org
COMMENT= Mesh and field I/O library and scientific database
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
-OPTIONS_DEFINE= HDF5 PYTHON
-OPTIONS_RADIO= EXCLUSIVE
-OPTIONS_RADIO_EXCLUSIVE= FORTRAN QT4
-OPTIONS_DEFAULT= QT4
-
-OPTIONS_SUB= yes
-
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared --disable-static
INSTALL_TARGET= install-strip
USES= gmake libtool readline
USE_LDCONFIG= yes
+OPTIONS_DEFINE= FORTRAN HDF5 PYTHON QT4
+OPTIONS_DEFAULT= HDF5
+OPTIONS_SUB= yes
+
FORTRAN_CONFIGURE_ENABLE= fortran
-FORTRAN_USE= FORTRAN=yes
+FORTRAN_USES= fortran
+
+HDF5_LIB_DEPENDS= libhdf5.so:${PORTSDIR}/science/hdf5
+HDF5_CONFIGURE_ON= --with-hdf5=${LOCALBASE}/include,${LOCALBASE}/lib
+HDF5_PLIST_SUB= SUFX_HDF5="h5"
+HDF5_PLIST_SUB_OFF= SUFX_HDF5=""
PYTHON_CONFIGURE_ENABLE= pythonmodule
-PYTHON_USE= PYTHON=yes
+PYTHON_USES= python:2
QT4_USE= XORG=xext,xi,xmu,xt \
QT4=gui,linguist_build,moc_build,uic_build
QT4_CONFIGURE_ON= --with-Qt-dir=${QT_PREFIX} \
--with-Qt-lib="QtGui -lQtCore"
+QT4_CONFIGURE_ENABLE= silex
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MHDF5}
-LIB_DEPENDS+= libhdf5.so:${PORTSDIR}/science/hdf5
-CONFIGURE_ARGS+= --with-hdf5=${LOCALBASE}/include,${LOCALBASE}/lib
-PLIST_SUB+= SUFX_HDF5="h5"
-.else
-PLIST_SUB+= SUFX_HDF5=""
-.endif
-
.if ${PORT_OPTIONS:MQT4}
QT_NONSTANDARD= yes
DESKTOP_ENTRIES="Silex" "Silex browser for Silo files" "" "silex" "" true
-.else
-CONFIGURE_ARGS+= --disable-silex
.endif
post-extract: