aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
Diffstat (limited to 'science')
-rw-r--r--science/lamprop/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/science/lamprop/Makefile b/science/lamprop/Makefile
index 9a1e6cf2fd79..fc14d1e4c6fd 100644
--- a/science/lamprop/Makefile
+++ b/science/lamprop/Makefile
@@ -27,9 +27,14 @@ MAKE_ENV= NOPORTDOCS=yes
PORTDOCS= LICENSE README NEWS
.endif
+.include <bsd.port.pre.mk>
+
+REP= 's|-pipe||; s|-fmerge-constants||; s|-fno-unit-at-a-time||; s|--fast-math||'
+.if ${ARCH} == "ia64"
+REP= 's|-pipe||; s|-fmerge-constants||; s|--fast-math||'
+.endif
+
post-patch:
- @${REINPLACE_CMD} -e \
- 's|-pipe||; s|-fmerge-constants||; s|-fno-unit-at-a-time||; s|--fast-math||' \
- ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e ${REP} ${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>