aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
Diffstat (limited to 'science')
-rw-r--r--science/psi3/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/science/psi3/Makefile b/science/psi3/Makefile
index 12e1e7519855..8543d34d8962 100644
--- a/science/psi3/Makefile
+++ b/science/psi3/Makefile
@@ -13,11 +13,11 @@ MASTER_SITES= ${MASTER_SITE_LOCAL} \
# http://www.psicode.org/downloads.php
MASTER_SITE_SUBDIR= maho/psi3
DISTNAME= psi-${PORTVERSION}
-EXTRACT_SUFX= .tar.bz2
.if !defined(NOPORTDOCS)
DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} installation.pdf:doc userman.pdf:doc progman.pdf:doc
.endif
DIST_SUBDIR= psi3
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= maho@FreeBSD.org
COMMENT= An electronic structure programs for high-accuracy computations
@@ -43,7 +43,7 @@ CONFIGURE_ARGS= --with-cc=${CC} \
FFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
CXXFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double -Wno-multichar
-.if (${MACHINE_ARCH} == "i386")
+.if (${ARCH} == "i386")
FFLAGS+= -mfancy-math-387
CFLAGS+= -mfancy-math-387
CXXFLAGS+= -mfancy-math-387