aboutsummaryrefslogtreecommitdiffstats
path: root/security/aide
diff options
context:
space:
mode:
Diffstat (limited to 'security/aide')
-rw-r--r--security/aide/Makefile20
-rw-r--r--security/aide/distinfo2
-rw-r--r--security/aide/files/patch-config.h.in11
-rw-r--r--security/aide/files/patch-configure10
-rw-r--r--security/aide/files/patch-src::conf_yacc.y67
5 files changed, 33 insertions, 77 deletions
diff --git a/security/aide/Makefile b/security/aide/Makefile
index a5963004f302..3c585a99d9d7 100644
--- a/security/aide/Makefile
+++ b/security/aide/Makefile
@@ -6,17 +6,29 @@
#
PORTNAME= aide
-PORTVERSION= 0.9
-PORTREVISION= 1
+PORTVERSION= 0.10
CATEGORIES= security
-MASTER_SITES= http://www.cs.tut.fi/~rammer/ \
- ftp://ftp.cs.tut.fi/pub/src/gnu/
+MASTER_SITE_SOURCEFORGE+= http://unc.dl.sourceforge.net/%SUBDIR%/ \
+ http://umn.dl.sourceforge.net/%SUBDIR%/ \
+ http://twtelecom.dl.sourceforge.net/%SUBDIR%/ \
+ http://aleron.dl.sourceforge.net/%SUBDIR%/ \
+ http://easynews.dl.sourceforge.net/%SUBDIR%/ \
+ http://switch.dl.sourceforge.net/%SUBDIR%/ \
+ http://cesnet.dl.sourceforge.net/%SUBDIR%/ \
+ http://flow.dl.sourceforge.net/%SUBDIR%/ \
+ http://keihanna.dl.sourceforge.net/%SUBDIR%/ \
+ http://heanet.dl.sourceforge.net/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://www.cs.tut.fi/~rammer/ \
+
MAINTAINER= cy@FreeBSD.org
COMMENT= A replacement and extension for Tripwire
LIB_DEPENDS= mhash.2:${PORTSDIR}/security/mhash
+USE_GMAKE= yes
USE_BISON= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-mhash \
diff --git a/security/aide/distinfo b/security/aide/distinfo
index 73bce195d4ce..78ab0f1b76b8 100644
--- a/security/aide/distinfo
+++ b/security/aide/distinfo
@@ -1 +1 @@
-MD5 (aide-0.9.tar.gz) = 877b1f515a9e25afda75e06805d687fb
+MD5 (aide-0.10.tar.gz) = 39eb7d21064cac7b409c45d038b86cd8
diff --git a/security/aide/files/patch-config.h.in b/security/aide/files/patch-config.h.in
new file mode 100644
index 000000000000..7a08dddf8531
--- /dev/null
+++ b/security/aide/files/patch-config.h.in
@@ -0,0 +1,11 @@
+--- config.h.in.orig Fri Nov 28 07:14:07 2003
++++ config.h.in Sat Jan 3 20:28:39 2004
+@@ -56,7 +56,7 @@
+ #define AIDE_STAT_TYPE stat
+ #define AIDE_INO_TYPE ino_t
+ #define AIDE_OFF_TYPE off_t
+-#define AIDE_BLKCNT_TYPE blkcnt_t
++#define AIDE_BLKCNT_TYPE int32_t
+
+ /* Defines for READDIR64 */
+ #define AIDE_READDIR_FUNC readdir
diff --git a/security/aide/files/patch-configure b/security/aide/files/patch-configure
index 01cc535cc2c2..7bb06ca03a0a 100644
--- a/security/aide/files/patch-configure
+++ b/security/aide/files/patch-configure
@@ -1,11 +1,11 @@
---- configure.orig Tue Jun 4 01:31:27 2002
-+++ configure Fri Jul 12 06:13:48 2002
-@@ -2838,7 +2838,7 @@
+--- configure.orig Fri Nov 28 07:14:08 2003
++++ configure Sat Jan 3 20:21:15 2004
+@@ -2885,7 +2885,7 @@
EOF
- cat >> confdefs.h <<EOF
+ cat >> confdefs.h <<EOF
-#define AIDE_BLKCNT_TYPE blkcnt_t
+#define AIDE_BLKCNT_TYPE int32_t
EOF
- compoptionstring="${compoptionstring}WITH_LSTAT\\n"
+ cat >> confdefs.h <<EOF
diff --git a/security/aide/files/patch-src::conf_yacc.y b/security/aide/files/patch-src::conf_yacc.y
deleted file mode 100644
index a517d3cbb142..000000000000
--- a/security/aide/files/patch-src::conf_yacc.y
+++ /dev/null
@@ -1,67 +0,0 @@
---- src/conf_yacc.y.orig Wed May 29 01:04:27 2002
-+++ src/conf_yacc.y Wed Nov 6 17:27:11 2002
-@@ -180,7 +180,7 @@
- conferror("Error in expression");
- YYABORT;
- }
-- }
-+ } ;
-
- other : TRIGHTS { $$ =$1 ;} | TUSER {$$ =$1 ;}
- | TGROUP {$$ =$1 ;} | TINODE {$$ =$1 ;}
-@@ -242,11 +242,11 @@
- beginconfigstmt : TBEGIN_CONFIG TSTRING {
- conf->do_configmd=1;
- conf->old_confmdstr=strdup($2);
--}
-+} ;
-
- endconfigstmt : TEND_CONFIG {
- YYACCEPT;
--}
-+} ;
-
- acl_no_symlink_follow : TACLNOSYMLINKFOLLOW TTRUE {
- #ifdef WITH_ACL
-@@ -254,7 +254,7 @@
- #else
- error(0,"ACL-support not compiled in.\n");
- #endif
--}
-+} ;
-
- acl_no_symlink_follow : TACLNOSYMLINKFOLLOW TFALSE {
- #ifdef WITH_ACL
-@@ -262,15 +262,15 @@
- #else
- error(0,"ACL-support not compiled in.\n");
- #endif
--}
-+} ;
-
- warn_dead_symlinks : TWARNDEADSYMLINKS TTRUE {
- conf->warn_dead_symlinks=1;
--}
-+} ;
-
- warn_dead_symlinks : TWARNDEADSYMLINKS TFALSE {
- conf->warn_dead_symlinks=0;
--}
-+} ;
-
- gzipdbout : TGZIPDBOUT TTRUE {
- #ifdef WITH_ZLIB
-@@ -288,11 +288,11 @@
- recursion_stopper : TRECSTOP TSTRING {
- /* FIXME implement me */
-
--}
-+} ;
-
- config_version : TCONFIG_VERSION TSTRING {
- conf->config_version=strdup($2);
--}
-+} ;
-
- %%
-
/span>/ * consensus, core, ethstats: use engine specific block beneficiary (#14318)Péter Szilágyi2017-04-122-2/+5 * consensus, core: drop all the legacy custom core error typesPéter Szilágyi2017-04-061-3/+2 * core, consensus: pluggable consensus engines (#3817)Péter Szilágyi2017-04-054-63/+27 * core: refactor genesis handlingFelix Lange2017-03-234-64/+33 * all: import "context" instead of "golang.org/x/net/context"Felix Lange2017-03-2312-26/+39 * les: implement request distributor, fix blocking issues (#3660)Felföldi Zsolt2017-03-232-11/+23 * Merge pull request #3779 from zsfelfoldi/cht-updatePéter Szilágyi2017-03-141-23/+2 |\ | * light: added new CHTZsolt Felfoldi2017-03-141-23/+2 * | all: swap out the C++ ethash to the pure Go one (mining todo)Péter Szilágyi2017-03-094-12/+11 |/ * all: update light logs (and a few others) to the new modelPéter Szilágyi2017-03-035-64/+16 * all: unify big.Int zero checks, use common/math in more places (#3716)Felix Lange2017-02-282-2/+2 * common: move big integer math to common/math (#3699)Felix Lange2017-02-271-4/+5 * all: blidly swap out glog to our log15, logs need reworkPéter Szilágyi2017-02-235-44/+42 * core, core/state, core/vm: remove exported account getters (#3618)Jeffrey Wilcke2017-02-232-20/+31 * logger: remove Core verbosity level (#3659)Felix Lange2017-02-152-4/+4 * params: core, core/vm, miner: 64bit gas instructionsJeffrey Wilcke2017-02-142-4/+6 * Revert "params: core, core/vm, miner: 64bit gas instructions (#3514)"Jeffrey Wilcke2017-02-132-6/+4 * Merge pull request #3605 from fjl/event-feedPéter Szilágyi2017-02-031-1/+1 |\ | * event: deprecate TypeMux and related typesFelix Lange2017-01-251-1/+1 * | params: core, core/vm, miner: 64bit gas instructions (#3514)Jeffrey Wilcke2017-02-022-4/+6 |/ * cmd/geth, core: add support for recording SHA3 preimages (#3543)Nick Johnson2017-01-173-2/+5 * Merge pull request #3519 from zsfelfoldi/light-topic5Péter Szilágyi2017-01-091-16/+19 |\ | * light: fixed data race in TestTxPoolZsolt Felfoldi2017-01-061-16/+19 * | all: gofmt -w -sFelix Lange2017-01-062-2/+2 * | Merge pull request #3516 from fjl/types-drop-sign-ecdsaPéter Szilágyi2017-01-062-7/+7 |\ \ | * | core/types: remove redundant SignECDSA wrappers, rename to SignTxFelix Lange2017-01-052-7/+7 | |/ * / core/vm: move Log to core/typesFelix Lange2017-01-061-1/+2 |/ * core/vm: improved EVM run loop & instruction calling (#3378)Jeffrey Wilcke2017-01-051-2/+2 * core, light: allow zero cost txs from inexistent accounts tooPéter Szilágyi2016-12-161-12/+1 * Merge pull request #3413 from zsfelfoldi/light-topic4Felix Lange2016-12-133-8/+23 |\ | * les, light: add block availability check for ODR requestsZsolt Felfoldi2016-12-102-8/+12 | * les: improved header fetcher and server statisticsZsolt Felfoldi2016-12-101-0/+11 * | core: bugfix state change race condition in txpool (#3412)bas-vk2016-12-111-2/+2 |/ * core, core/vm: implemented a generic environment (#3348)Jeffrey Wilcke2016-12-064-103/+40 * light: implemented VMState.Empty() (#3357)Felföldi Zsolt2016-11-282-2/+14 * core: implemented new ropsten testnetJeffrey Wilcke2016-11-231-1/+0 * cmd/geth, core, light, mobile: removed state account StartingNonceJeffrey Wilcke2016-11-231-4/+1 * core/types: turn off nonce checking for Call messagesZsolt Felfoldi2016-11-141-2/+2 * light: updated CHTs for mainnet and testnetZsolt Felfoldi2016-11-141-4/+4 * core/types, params: EIP#155Jeffrey Wilcke2016-11-134-69/+24 * core, core/state, trie: EIP158, reprice & skip empty account writeJeffrey Wilcke2016-11-137-22/+28 * all: update license informationFelix Lange2016-11-097-6/+24 * core/types: remove header accessorsFelix Lange2016-11-094-10/+10 * p2p/discv5: added new topic discovery packageZsolt Felfoldi2016-11-091-4/+4 * light: light chain, VM env and tx poolZsolt Felfoldi2016-11-0912-97/+2558 * trie, core/state: improve memory usage and performance (#3135)Felix Lange2016-10-151-3/+3 * core/state: implement reverts by journaling all changesFelix Lange2016-10-061-9/+5 * cmd, core, internal, light, tests: avoid hashing the code in the VMPéter Szilágyi2016-10-011-1/+2 * core, trie: replace state caches with trie journalFelix Lange2016-09-281-4/+0 * core/state: track all accounts in canon stateFelix Lange2016-09-261-1/+1 * light: fix memory expansion bug (same as fix for core/state)Gustav Simonsson2016-09-202-2/+4 * core/state, light: remove unused StateObject.initCodeGustav Simonsson2016-09-191-3/+0 * all: update license informationFelix Lange2016-04-151-1/+1 * all: Rename crypto.Sha3{,Hash}() to crypto.Keccak256{,Hash}()Ricardo Catalinas Jiménez2016-02-222-4/+4 * rpc: migrated the RPC insterface to a new reflection based RPC layerBas van Kervel2016-01-261-1/+1 * light: implemented odr-capable trie and state structureszsfelfoldi2015-12-17