aboutsummaryrefslogtreecommitdiffstats
path: root/security/clamav-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/clamav-devel/Makefile')
-rw-r--r--security/clamav-devel/Makefile35
1 files changed, 22 insertions, 13 deletions
diff --git a/security/clamav-devel/Makefile b/security/clamav-devel/Makefile
index 9f1a412b6d62..7ace63eca5fa 100644
--- a/security/clamav-devel/Makefile
+++ b/security/clamav-devel/Makefile
@@ -1,17 +1,20 @@
-# New ports collection makefile for: clamav
-# Date created: 15 July 2002
-# Whom: markun@onohara.to
+# New ports collection makefile for: clamav-devel
+# Date created: 13 June 2003
+# Whom: Rob Evers <rob@debank.tv>
#
# $FreeBSD$
#
PORTNAME= clamav
-PORTVERSION= 0.60
+PORTVERSION= 20030625
CATEGORIES= security
-MASTER_SITES= http://clamav.elektrapro.com/stable/ \
- http://clamav.essentkabel.com/stable/
+MASTER_SITES= http://clamav.elektrapro.com/snapshot/ \
+ http://clamav.essentkabel.com/snapshot/ \
+ http://clamav.ozforces.com/ \
+ http://clamav.rulez.pl/snapshot/
+PKGNAMESUFFIX= -devel
-MAINTAINER= markun@onohara.to
+MAINTAINER= rob@debank.tv
COMMENT= Command line virus scanner written entirely in C
RUN_DEPENDS= lha:${PORTSDIR}/archivers/lha \
@@ -23,26 +26,32 @@ RUN_DEPENDS= lha:${PORTSDIR}/archivers/lha \
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
- --disable-clamav \
- --enable-bigstack
+ --disable-clamav
-MAN1= clamscan.1 freshclam.1 sigtool.1 clamdscan.1 clamav-milter.1
+MAN1= clamscan.1 freshclam.1 sigtool.1 clamdscan.1
MAN5= clamav.conf.5
MAN8= clamd.8
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 500000
+CONFIGURE_ARGS+= --enable-milter
+PLIST_SUB+= CLAMAV-MILTER:=""
+.else
+PLIST_SUB+= CLAMAV-MILTER:="@comment "
+.endif
+
pre-install:
- @${ECHO} "===> Creating custom user to run clamav..."
+ @${ECHO} "===> Creating custom user to run clamav..."
${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
- @${ECHO} "===> Setting permissions..."
+ @${ECHO} "===> Setting permissions..."
@${SETENV} PKG_PREFIX=${PREFIX} ${sh} \
${SH} ${PKGINSTALL} ${PREFIX} POST-INSTALL