aboutsummaryrefslogtreecommitdiffstats
path: root/security/dazuko
diff options
context:
space:
mode:
Diffstat (limited to 'security/dazuko')
-rw-r--r--security/dazuko/Makefile48
-rw-r--r--security/dazuko/distinfo2
-rw-r--r--security/dazuko/files/pkg-message.in16
-rw-r--r--security/dazuko/pkg-deinstall27
-rw-r--r--security/dazuko/pkg-descr6
-rw-r--r--security/dazuko/pkg-install33
6 files changed, 0 insertions, 132 deletions
diff --git a/security/dazuko/Makefile b/security/dazuko/Makefile
deleted file mode 100644
index 83436f8f6dd1..000000000000
--- a/security/dazuko/Makefile
+++ /dev/null
@@ -1,48 +0,0 @@
-# Created by: Rob Evers <rob@debank.tv>
-# $FreeBSD$
-
-PORTNAME= dazuko
-PORTVERSION= 2.3.9
-CATEGORIES= security
-MASTER_SITES= http://dazuko.dnsalias.org/files/
-
-MAINTAINER= acm@FreeBSD.org
-COMMENT= Common interface for 3rd party file access control
-
-HAS_CONFIGURE= yes
-SUB_FILES= pkg-message
-
-BROKEN= does not compile on freebsd version > 8.x
-DEPRECATED= Currently, the project has not an active development and maintainer
-EXPIRATION_DATE= 2013-12-30
-
-OPTIONS_DEFINE= EXAMPLEC
-OPTIONS_DEFAULT= EXAMPLEC
-EXAMPLEC_DESC= Install C example programs
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MEXAMPLEC}
-PLIST_FILES= %%EXAMPLESDIR%%/example %%EXAMPLESDIR%%/example_mt
-PLIST_DIRS= %%EXAMPLESDIR%%
-.endif
-
-post-configure:
- ${REINPLACE_CMD} -e 's|^NOMAN|NO_MAN|g' ${WRKSRC}/library/Makefile
-
-do-install:
-.if ${PORT_OPTIONS:MEXAMPLEC}
- @cd ${WRKSRC}/example_c && \
- ${MAKE}
- @${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/example_c/example ${WRKSRC}/example_c/example_mt ${EXAMPLESDIR}
-.endif
-
- @${SETENV} ${MAKE_ENV} ${MAKE} -C ${WRKSRC} -DMODULES_WITH_WORLD install
-
-post-install:
- @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>
diff --git a/security/dazuko/distinfo b/security/dazuko/distinfo
deleted file mode 100644
index d5e2e7853871..000000000000
--- a/security/dazuko/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (dazuko-2.3.9.tar.gz) = c66e0c7e4eda07fcb47bdbd55b782ece68cb7494fcd91171876bafcaed230d96
-SIZE (dazuko-2.3.9.tar.gz) = 207609
diff --git a/security/dazuko/files/pkg-message.in b/security/dazuko/files/pkg-message.in
deleted file mode 100644
index 0e4cc60d48a9..000000000000
--- a/security/dazuko/files/pkg-message.in
+++ /dev/null
@@ -1,16 +0,0 @@
-################################################################################
-
-1) If you selected WITH_EXAMPLEC, you can test the module using files from:
-
- %%EXAMPLESDIR%%/example
- %%EXAMPLESDIR%%/example_mt
-
-2) Do not load the module using /boot/loader.conf. It generates a page fault due
- to a possible dazuko bug.
-
- You could use /etc/rc.local for loading the module. For example, add the
- following line to /etc/rc.local:
-
- /sbin/kldload dazuko
-
-################################################################################
diff --git a/security/dazuko/pkg-deinstall b/security/dazuko/pkg-deinstall
deleted file mode 100644
index e2ccccd2ea1e..000000000000
--- a/security/dazuko/pkg-deinstall
+++ /dev/null
@@ -1,27 +0,0 @@
-if [ ! "$2" = "POST-DEINSTALL" ]; then
- MODULENAME=dazuko
- FREEBSDVER=`uname -r | cut -f 1 -d .`
-
- kldstat -n ${MODULENAME} > /dev/null 2>&1; RESULT=$?
- if [ ${RESULT} -eq 0 ]; then
- kldunload -f -n ${MODULENAME}
- fi
-
- if [ "${FREEBSDVER}" = "4" ]; then
- rm /modules/${MODULENAME}.ko
- else
- rm /boot/modules/${MODULENAME}.ko
- fi
-
- if [ -f /boot/modules/linker.hints ]; then
- rm /boot/modules/linker.hints
- fi
-
- if [ -f /boot/loader.conf ]; then
- cat /etc/rc.local | grep ${MODULENAME} > /dev/null 2>&1; RESULT=$?
- if [ ${RESULT} -eq 0 ]; then
- sed -i '' -e "/${MODULENAME}/d" /etc/rc.local
- fi
- fi
-fi
-exit 0
diff --git a/security/dazuko/pkg-descr b/security/dazuko/pkg-descr
deleted file mode 100644
index a8f4ebdfeb7b..000000000000
--- a/security/dazuko/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-A common interface across all platforms is needed for 3rd party file
-access control. With such an interface, focus could be redirected
-from OS hacking to solving real problems. The interface is here. It
-is called Dazuko.
-
-WWW: http://dazuko.org/
diff --git a/security/dazuko/pkg-install b/security/dazuko/pkg-install
deleted file mode 100644
index d15ecad43dab..000000000000
--- a/security/dazuko/pkg-install
+++ /dev/null
@@ -1,33 +0,0 @@
-#!/bin/sh
-
-if [ "$2" = "POST-INSTALL" ]; then
-
-MODULENAME=dazuko
-
-echo -n "Do you want load ${MODULENAME}.ko? [ y/n ]: "
-read LOADMOD
-echo
-
- if [ x"${LOADMOD}" = x"y" ]; then
- kldstat -n ${MODULENAME} > /dev/null 2>&1; RESULT=$?
- if [ ${RESULT} -eq 0 ]; then
- kldunload -f -n ${MODULENAME}
- fi
- kldload ${MODULENAME}
- fi
-
-echo -n "Do you want load ${MODULENAME}.ko in /etc/rc.local file? [ y/n ]: "
-read BOOTMOD
-echo
-
- if [ x"${BOOTMOD}" = x"y" ]; then
- cat /etc/rc.local | grep ${MODULENAME} > /dev/null 2>&1; RESULT=$?
- if [ ${RESULT} -eq 0 ]; then
- sed -i '' -e '/kldload ${MODULENAME}.*/d' /etc/rc.local
- echo `which kldload` ${MODULENAME} >> /etc/rc.local
- else
- echo `which kldload` ${MODULENAME} >> /etc/rc.local
- fi
- fi
-fi
-exit 0