aboutsummaryrefslogtreecommitdiffstats
path: root/security/dirmngr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/dirmngr/Makefile')
-rw-r--r--security/dirmngr/Makefile40
1 files changed, 10 insertions, 30 deletions
diff --git a/security/dirmngr/Makefile b/security/dirmngr/Makefile
index e9af4effc172..68e589bfae14 100644
--- a/security/dirmngr/Makefile
+++ b/security/dirmngr/Makefile
@@ -6,45 +6,25 @@
#
PORTNAME= dirmngr
-PORTVERSION= 0.4.5
-PORTREVISION= 3
+PORTVERSION= 0.5.3
CATEGORIES= security
-MASTER_SITES= ${MASTER_SITE_GNUPG} \
- http://tigress.com/lofi/:lofi/
-MASTER_SITE_SUBDIR= alpha/aegypten
-DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz \
- common.tar.gz:lofi
+MASTER_SITES= ${MASTER_SITE_GNUPG}
+MASTER_SITE_SUBDIR= alpha/dirmngr
+DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz
MAINTAINER= lofi@freebsd.org
COMMENT= A client for managing and downloading certificate revocation lists
-LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db2 \
- gcrypt.6:${PORTSDIR}/security/libgcrypt \
- ksba.7:${PORTSDIR}/security/libksba
+BUILD_DEPENDS= ${LOCALBASE}/lib/libassuan.a:${PORTSDIR}/security/libassuan
+LIB_DEPENDS= gcrypt.12:${PORTSDIR}/security/libgcrypt \
+ gpg-error:${PORTSDIR}/security/libgpg-error \
+ ksba.11:${PORTSDIR}/security/libksba
USE_OPENLDAP= yes
USE_GETOPT_LONG=yes
-USE_AUTOMAKE_VER= 15
USE_LIBTOOL_VER=13
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
-USE_REINPLACE= yes
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-LDFLAGS+= -L${LOCALBASE}/lib
-CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
-CONFIGURE_ARGS+=--with-included-gettext=no
+USE_GETTEXT= yes
INFO= dirmngr
-PLIST_FILES= bin/dirmngr
-.include <bsd.port.pre.mk>
-
-post-extract:
- ${MV} ${WRKDIR}/common ${WRKSRC}
-
-pre-configure:
- ${REINPLACE_CMD} -e "s@-lpthread@${PTHREAD_LIBS}@g" \
- ${WRKSRC}/acinclude.m4 ${WRKSRC}/aclocal.m4 ${WRKSRC}/configure
- cd ${WRKSRC}; ./autogen.sh
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>