aboutsummaryrefslogtreecommitdiffstats
path: root/security/gnupg-idea/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/gnupg-idea/Makefile')
-rw-r--r--security/gnupg-idea/Makefile24
1 files changed, 16 insertions, 8 deletions
diff --git a/security/gnupg-idea/Makefile b/security/gnupg-idea/Makefile
index b4ca7ddc8393..65c1c4eb11a4 100644
--- a/security/gnupg-idea/Makefile
+++ b/security/gnupg-idea/Makefile
@@ -25,18 +25,14 @@ pre-fetch:
@${ECHO_MSG} You must set variable USA_RESIDENT to YES, if you are USA resident
@${ECHO_MSG} or to NO, if you aren\'t USA resident to build this package
@${FALSE}
-.endif
+
+.include <bsd.port.mk>
+
+.elif defined(USA_RESIDENT)
.if ${USA_RESIDENT} == NO
DISTFILES= rsa.c idea.c
CONTRIB= rsa idea
-#EXTRACT_ONLY=
-.else
-do-fetch:
- @${ECHO_MSG}
- @${ECHO_MSG} rsaref not yet supported
- @${FALSE}
-.endif
.include <bsd.port.pre.mk>
@@ -58,3 +54,15 @@ do-install:
.endfor
.include <bsd.port.post.mk>
+
+.else
+pre-fetch:
+ @${ECHO_MSG}
+ @${ECHO_MSG} rsaref is not supported in this port
+ @${FALSE}
+
+.include <bsd.port.mk>
+
+.endif
+
+.endif