aboutsummaryrefslogtreecommitdiffstats
path: root/security/hashcat
diff options
context:
space:
mode:
Diffstat (limited to 'security/hashcat')
-rw-r--r--security/hashcat/Makefile26
-rw-r--r--security/hashcat/distinfo5
-rw-r--r--security/hashcat/files/patch-include_common.h14
-rw-r--r--security/hashcat/files/patch-include_ext__OpenCL.h13
-rw-r--r--security/hashcat/files/patch-src_Makefile52
-rw-r--r--security/hashcat/files/patch-src_hashcat-cli.c95
-rw-r--r--security/hashcat/files/patch-src_hashcat.c20
-rw-r--r--security/hashcat/files/patch-src_shared.c67
-rw-r--r--security/hashcat/pkg-message6
-rw-r--r--security/hashcat/pkg-plist492
10 files changed, 613 insertions, 177 deletions
diff --git a/security/hashcat/Makefile b/security/hashcat/Makefile
index 3dc2777db8a3..afd9820c0107 100644
--- a/security/hashcat/Makefile
+++ b/security/hashcat/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= hashcat
-PORTVERSION= 2.00
+PORTVERSION= 3.00
CATEGORIES= security
MAINTAINER= lifanov@mail.lifanov.com
@@ -11,26 +11,20 @@ COMMENT= Advanced CPU-based password recovery utility
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/docs/license.txt
+BUILD_DEPENDS= ${LOCALBASE}/include/CL/cl.h:devel/opencl \
+ ${LOCALBASE}/bin/gsed:textproc/gsed
+
BROKEN_FreeBSD_9= does not build
USE_GITHUB= yes
GH_ACCOUNT= hashcat
+GH_TAGNAME= v${PORTVERSION}
-USE_GCC= any
-
-USES= gmake
-
-ONLY_FOR_ARCHS= amd64
-ONLY_FOR_ARCHS_REASON= uses amd64 instructions
-
-ALL_TARGET= posix64 posixXOP
+ALL_TARGET= native
+USES= gmake localbase
+USE_CSTD= c99
-do-install:
-.for v in 64 XOP
- ${INSTALL_PROGRAM} ${WRKSRC}/hashcat-cli${v}.bin ${STAGEDIR}${LOCALBASE}/bin
-.endfor
- (cd ${WRKSRC} && ${COPYTREE_SHARE} "charsets rules tables salts" ${STAGEDIR}${DATADIR})
- (cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
- (cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
+pre-install:
+ ${STRIP_CMD} ${WRKSRC}/hashcat
.include <bsd.port.mk>
diff --git a/security/hashcat/distinfo b/security/hashcat/distinfo
index edeb017614d7..b2d5940b2d67 100644
--- a/security/hashcat/distinfo
+++ b/security/hashcat/distinfo
@@ -1,2 +1,3 @@
-SHA256 (hashcat-hashcat-2.00_GH0.tar.gz) = 6325e6d75a4df3485adec00f74e5887326809c15ed31bfe74a12b62943245444
-SIZE (hashcat-hashcat-2.00_GH0.tar.gz) = 3463012
+TIMESTAMP = 1467810332
+SHA256 (hashcat-hashcat-3.00-v3.00_GH0.tar.gz) = 0283791b91db9dd7ee7431d8975c63419c73232945b76eedcefbe12becfa19c4
+SIZE (hashcat-hashcat-3.00-v3.00_GH0.tar.gz) = 4068649
diff --git a/security/hashcat/files/patch-include_common.h b/security/hashcat/files/patch-include_common.h
new file mode 100644
index 000000000000..bf13aed556fe
--- /dev/null
+++ b/security/hashcat/files/patch-include_common.h
@@ -0,0 +1,14 @@
+--- include/common.h.orig 2016-06-28 09:47:32 UTC
++++ include/common.h
+@@ -51,6 +51,11 @@
+ #include <mach/mach.h>
+ #endif
+
++#ifdef __FreeBSD__
++#include <termios.h>
++#include <sys/ioctl.h>
++#endif
++
+ typedef void *OCL_LIB;
+
+ #ifdef HAVE_HWMON
diff --git a/security/hashcat/files/patch-include_ext__OpenCL.h b/security/hashcat/files/patch-include_ext__OpenCL.h
new file mode 100644
index 000000000000..bdeb44a14e34
--- /dev/null
+++ b/security/hashcat/files/patch-include_ext__OpenCL.h
@@ -0,0 +1,13 @@
+--- include/ext_OpenCL.h.orig 2016-06-28 09:47:32 UTC
++++ include/ext_OpenCL.h
+@@ -27,6 +27,10 @@
+ // #include <CL/cl_ext.h> // used for CL_DEVICE_TOPOLOGY_AMD but broken for dual GPU
+ #endif
+
++#ifdef __FreeBSD__
++#include <CL/cl.h>
++#endif
++
+ #include <shared.h>
+
+ typedef cl_mem (CL_API_CALL *OCL_CLCREATEBUFFER) (cl_context, cl_mem_flags, size_t, void *, cl_int *);
diff --git a/security/hashcat/files/patch-src_Makefile b/security/hashcat/files/patch-src_Makefile
new file mode 100644
index 000000000000..7d1c2e3d5a40
--- /dev/null
+++ b/security/hashcat/files/patch-src_Makefile
@@ -0,0 +1,52 @@
+--- src/Makefile.orig 2016-06-28 09:47:32 UTC
++++ src/Makefile
+@@ -17,7 +17,7 @@ UNAME := $(shell unam
+ # we need to strip the windows version number to be able to build hashcat on cygwin hosts
+ UNAME := $(patsubst CYGWIN_NT-%,CYGWIN_NT-,$(UNAME))
+
+-ifeq (,$(filter $(UNAME),Linux Darwin CYGWIN_NT-))
++ifeq (,$(filter $(UNAME),Linux Darwin CYGWIN_NT- FreeBSD))
+ $(error "! Your Operating System ($(UNAME)) is not supported by $(PROG_NAME) Makefile")
+ endif
+
+@@ -58,7 +58,6 @@ OPENCL_HEADERS_KHRONOS := deps/OpenCL-
+ ## Native compiler paths
+ ##
+
+-CC := gcc
+ FIND := find
+ INSTALL := install
+ RM := rm
+@@ -87,7 +86,7 @@ VERSION_TAG := $(shell test
+ ## Compiler flags
+ ##
+
+-CFLAGS := -pipe -W -Wall -std=c99 -Iinclude/ -IOpenCL/ -I$(OPENCL_HEADERS_KHRONOS)/
++CFLAGS += -Iinclude/ -IOpenCL/ -I$(OPENCL_HEADERS_KHRONOS)/
+
+ ifndef DEBUG
+ CFLAGS += -O2
+@@ -97,6 +96,9 @@ ifeq ($(DEBUG),2)
+ CFLAGS += -fsanitize=address -fno-omit-frame-pointer
+ endif
+ endif
++ifeq ($(UNAME),FreeBSD)
++SED := gsed
++endif
+
+ ##
+ ## Native compilation target
+@@ -122,6 +124,13 @@ LFLAGS_NATIVE := -lpthread -l
+ CFLAGS_NATIVE += -DHAVE_HWMON
+ endif # linux
+
++ifeq ($(UNAME),FreeBSD)
++CFLAGS_NATIVE := -D_POSIX
++CFLAGS_NATIVE += $(CFLAGS)
++LFLAGS_NATIVE := -lpthread
++LFLAGS_NATIVE += $(LDFLAGS)
++endif # freebsd
++
+ ##
+ ## Cross compilation target
+ ##
diff --git a/security/hashcat/files/patch-src_hashcat-cli.c b/security/hashcat/files/patch-src_hashcat-cli.c
deleted file mode 100644
index b792639b61f0..000000000000
--- a/security/hashcat/files/patch-src_hashcat-cli.c
+++ /dev/null
@@ -1,95 +0,0 @@
---- src/hashcat-cli.c.orig 2015-12-04 15:35:08 UTC
-+++ src/hashcat-cli.c
-@@ -17,14 +17,14 @@
-
- // for interactive status prompt
- #ifdef POSIX
--#ifndef OSX
-+#if defined(OSX) || defined(__FreeBSD__)
-
--#include <termio.h>
-+#include <termios.h>
-+#include <sys/ioctl.h>
-
- #else
-
--#include <termios.h>
--#include <sys/ioctl.h>
-+#include <termio.h>
-
- #endif
- #endif
-@@ -2836,16 +2836,16 @@ void save_hash ()
-
- #ifdef POSIX
-
--#ifndef OSX
-+#if defined(OSX) || defined(__FreeBSD__)
-
--static struct termio savemodes;
-+static struct termios savemodes;
- static int havemodes = 0;
-
- int tty_break ()
- {
-- struct termio modmodes;
-+ struct termios modmodes;
-
-- if (ioctl (fileno (stdin), TCGETA, &savemodes) < 0) return -1;
-+ if (ioctl (fileno (stdin), TIOCGETA, &savemodes) < 0) return -1;
-
- havemodes = 1;
-
-@@ -2854,7 +2854,7 @@ int tty_break ()
- modmodes.c_cc[VMIN] = 1;
- modmodes.c_cc[VTIME] = 0;
-
-- return ioctl (fileno (stdin), TCSETAW, &modmodes);
-+ return ioctl (fileno (stdin), TIOCSETAW, &modmodes);
- }
-
- int tty_getchar ()
-@@ -2882,19 +2882,19 @@ int tty_fix ()
- {
- if (!havemodes) return 0;
-
-- return ioctl (fileno (stdin), TCSETAW, &savemodes);
-+ return ioctl (fileno (stdin), TIOCSETAW, &savemodes);
- }
-
- #else
-
--static struct termios savemodes;
-+static struct termio savemodes;
- static int havemodes = 0;
-
- int tty_break ()
- {
-- struct termios modmodes;
-+ struct termio modmodes;
-
-- if (ioctl (fileno (stdin), TIOCGETA, &savemodes) < 0) return -1;
-+ if (ioctl (fileno (stdin), TCGETA, &savemodes) < 0) return -1;
-
- havemodes = 1;
-
-@@ -2903,7 +2903,7 @@ int tty_break ()
- modmodes.c_cc[VMIN] = 1;
- modmodes.c_cc[VTIME] = 0;
-
-- return ioctl (fileno (stdin), TIOCSETAW, &modmodes);
-+ return ioctl (fileno (stdin), TCSETAW, &modmodes);
- }
-
- int tty_getchar ()
-@@ -2931,8 +2931,9 @@ int tty_fix ()
- {
- if (!havemodes) return 0;
-
-- return ioctl (fileno (stdin), TIOCSETAW, &savemodes);
-+ return ioctl (fileno (stdin), TCSETAW, &savemodes);
- }
-+
- #endif
- #endif
-
diff --git a/security/hashcat/files/patch-src_hashcat.c b/security/hashcat/files/patch-src_hashcat.c
new file mode 100644
index 000000000000..c1bb3ccc5111
--- /dev/null
+++ b/security/hashcat/files/patch-src_hashcat.c
@@ -0,0 +1,20 @@
+--- src/hashcat.c.orig 2016-06-28 09:47:32 UTC
++++ src/hashcat.c
+@@ -6,7 +6,7 @@
+ * License.....: MIT
+ */
+
+-#ifdef DARWIN
++#if defined(DARWIN) || defined(__FreeBSD__)
+ #include <stdio.h>
+ #endif
+
+@@ -6134,7 +6134,7 @@ int main (int argc, char **argv)
+
+ char *exec_path = get_exec_path ();
+
+- #ifdef LINUX
++ #if defined(LINUX) || defined(__FreeBSD__)
+
+ char *resolved_install_folder = realpath (INSTALL_FOLDER, NULL);
+ char *resolved_exec_path = realpath (exec_path, NULL);
diff --git a/security/hashcat/files/patch-src_shared.c b/security/hashcat/files/patch-src_shared.c
new file mode 100644
index 000000000000..348ef3498f24
--- /dev/null
+++ b/security/hashcat/files/patch-src_shared.c
@@ -0,0 +1,67 @@
+--- src/shared.c.orig 2016-06-28 09:47:32 UTC
++++ src/shared.c
+@@ -10,6 +10,11 @@
+ #include <stdio.h>
+ #endif
+
++#ifdef __FreeBSD__
++#include <stdio.h>
++#include <pthread_np.h>
++#endif
++
+ #include <shared.h>
+ #include <limits.h>
+
+@@ -2382,7 +2387,7 @@ int tty_fix()
+ }
+ #endif
+
+-#ifdef DARWIN
++#if defined(DARWIN) || defined(__FreeBSD__)
+ static struct termios savemodes;
+ static int havemodes = 0;
+
+@@ -4371,6 +4376,23 @@ char *get_exec_path ()
+
+ const int len = strlen (exec_path);
+
++ #elif __FreeBSD__
++
++ #include <sys/sysctl.h>
++
++ int mib[4];
++ mib[0] = CTL_KERN;
++ mib[1] = KERN_PROC;
++ mib[2] = KERN_PROC_PATHNAME;
++ mib[3] = -1;
++
++ char tmp[32] = { 0 };
++
++ size_t size = exec_path_len;
++ sysctl(mib, 4, exec_path, &size, NULL, 0);
++
++ const int len = readlink (tmp, exec_path, exec_path_len - 1);
++
+ #else
+ #error Your Operating System is not supported or detected
+ #endif
+@@ -4523,6 +4545,9 @@ void set_cpu_affinity (char *cpu_affinit
+ {
+ #ifdef _WIN
+ DWORD_PTR aff_mask = 0;
++ #elif __FreeBSD__
++ cpuset_t cpuset;
++ CPU_ZERO (&cpuset);
+ #elif _POSIX
+ cpu_set_t cpuset;
+ CPU_ZERO (&cpuset);
+@@ -4570,6 +4595,9 @@ void set_cpu_affinity (char *cpu_affinit
+ #ifdef _WIN
+ SetProcessAffinityMask (GetCurrentProcess (), aff_mask);
+ SetThreadAffinityMask (GetCurrentThread (), aff_mask);
++ #elif __FreeBSD__
++ pthread_t thread = pthread_self ();
++ pthread_setaffinity_np (thread, sizeof (cpuset_t), &cpuset);
+ #elif _POSIX
+ pthread_t thread = pthread_self ();
+ pthread_setaffinity_np (thread, sizeof (cpu_set_t), &cpuset);
diff --git a/security/hashcat/pkg-message b/security/hashcat/pkg-message
new file mode 100644
index 000000000000..b01821f17825
--- /dev/null
+++ b/security/hashcat/pkg-message
@@ -0,0 +1,6 @@
+This port requires an OpenCL runtime.
+Please see this for information on how to obtain one:
+https://wiki.freebsd.org/Graphics/OpenCL
+
+If it is not possible to obtain an OpenCL runtime,
+please use security/hashcat-legacy instead.
diff --git a/security/hashcat/pkg-plist b/security/hashcat/pkg-plist
index f0d92c033a58..762b991edc10 100644
--- a/security/hashcat/pkg-plist
+++ b/security/hashcat/pkg-plist
@@ -1,58 +1,384 @@
-bin/hashcat-cli64.bin
-bin/hashcat-cliXOP.bin
-%%PORTDOCS%%%%DOCSDIR%%/BUILD.md
-%%PORTDOCS%%%%DOCSDIR%%/changes.txt
-%%PORTDOCS%%%%DOCSDIR%%/contact.txt
-%%PORTDOCS%%%%DOCSDIR%%/credits.txt
-%%PORTDOCS%%%%DOCSDIR%%/license.txt
-%%PORTDOCS%%%%DOCSDIR%%/rules.txt
-%%PORTDOCS%%%%DOCSDIR%%/user_manuals.txt
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M0.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M0.word
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M10.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M10.word
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M100.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M100.word
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1000.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1000.word
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M101.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M101.word
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1100.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1100.word
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1400.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1400.word
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1410.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1410.word
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1420.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1420.word
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1600.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1600.word
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1700.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1700.word
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1710.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1710.word
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1720.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1720.word
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1731.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1731.word
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1800.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M1800.word
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M200.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M200.word
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M300.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M300.word
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M400.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M400.word
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M500.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M500.word
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M800.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M800.word
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M900.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A0.M900.word
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A1.M0.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A1.M0.word
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A3.M0.hash
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/A3.M0.word
+bin/hashcat
+%%PORTDOCS%%%%DOCSDIR%%/docs/changes.txt
+%%PORTDOCS%%%%DOCSDIR%%/docs/contact.txt
+%%PORTDOCS%%%%DOCSDIR%%/docs/license.txt
+%%PORTDOCS%%%%DOCSDIR%%/docs/performance.txt
+%%PORTDOCS%%%%DOCSDIR%%/docs/readme.txt
+%%PORTDOCS%%%%DOCSDIR%%/docs/rules.txt
+%%PORTDOCS%%%%DOCSDIR%%/docs/status_codes.txt
+%%PORTDOCS%%%%DOCSDIR%%/docs/user_manuals.txt
+%%PORTDOCS%%%%DOCSDIR%%/example.dict
+%%PORTDOCS%%%%DOCSDIR%%/example0.hash
+%%PORTDOCS%%%%DOCSDIR%%/example0.sh
+%%PORTDOCS%%%%DOCSDIR%%/example400.hash
+%%PORTDOCS%%%%DOCSDIR%%/example400.sh
+%%PORTDOCS%%%%DOCSDIR%%/example500.hash
+%%PORTDOCS%%%%DOCSDIR%%/example500.sh
+%%PORTDOCS%%%%DOCSDIR%%/extra/tab_completion/hashcat.sh
+%%PORTDOCS%%%%DOCSDIR%%/extra/tab_completion/howto.txt
+%%PORTDOCS%%%%DOCSDIR%%/extra/tab_completion/install
+%%DATADIR%%/OpenCL/amp_a0.cl
+%%DATADIR%%/OpenCL/amp_a1.cl
+%%DATADIR%%/OpenCL/amp_a3.cl
+%%DATADIR%%/OpenCL/inc_cipher_aes256.cl
+%%DATADIR%%/OpenCL/inc_cipher_serpent256.cl
+%%DATADIR%%/OpenCL/inc_cipher_twofish256.cl
+%%DATADIR%%/OpenCL/inc_common.cl
+%%DATADIR%%/OpenCL/inc_comp_multi.cl
+%%DATADIR%%/OpenCL/inc_comp_multi_bs.cl
+%%DATADIR%%/OpenCL/inc_comp_single.cl
+%%DATADIR%%/OpenCL/inc_comp_single_bs.cl
+%%DATADIR%%/OpenCL/inc_hash_constants.h
+%%DATADIR%%/OpenCL/inc_hash_functions.cl
+%%DATADIR%%/OpenCL/inc_rp.cl
+%%DATADIR%%/OpenCL/inc_rp.h
+%%DATADIR%%/OpenCL/inc_simd.cl
+%%DATADIR%%/OpenCL/inc_types.cl
+%%DATADIR%%/OpenCL/inc_vendor.cl
+%%DATADIR%%/OpenCL/m00000_a0.cl
+%%DATADIR%%/OpenCL/m00000_a1.cl
+%%DATADIR%%/OpenCL/m00000_a3.cl
+%%DATADIR%%/OpenCL/m00010_a0.cl
+%%DATADIR%%/OpenCL/m00010_a1.cl
+%%DATADIR%%/OpenCL/m00010_a3.cl
+%%DATADIR%%/OpenCL/m00020_a0.cl
+%%DATADIR%%/OpenCL/m00020_a1.cl
+%%DATADIR%%/OpenCL/m00020_a3.cl
+%%DATADIR%%/OpenCL/m00030_a0.cl
+%%DATADIR%%/OpenCL/m00030_a1.cl
+%%DATADIR%%/OpenCL/m00030_a3.cl
+%%DATADIR%%/OpenCL/m00040_a0.cl
+%%DATADIR%%/OpenCL/m00040_a1.cl
+%%DATADIR%%/OpenCL/m00040_a3.cl
+%%DATADIR%%/OpenCL/m00050_a0.cl
+%%DATADIR%%/OpenCL/m00050_a1.cl
+%%DATADIR%%/OpenCL/m00050_a3.cl
+%%DATADIR%%/OpenCL/m00060_a0.cl
+%%DATADIR%%/OpenCL/m00060_a1.cl
+%%DATADIR%%/OpenCL/m00060_a3.cl
+%%DATADIR%%/OpenCL/m00100_a0.cl
+%%DATADIR%%/OpenCL/m00100_a1.cl
+%%DATADIR%%/OpenCL/m00100_a3.cl
+%%DATADIR%%/OpenCL/m00110_a0.cl
+%%DATADIR%%/OpenCL/m00110_a1.cl
+%%DATADIR%%/OpenCL/m00110_a3.cl
+%%DATADIR%%/OpenCL/m00120_a0.cl
+%%DATADIR%%/OpenCL/m00120_a1.cl
+%%DATADIR%%/OpenCL/m00120_a3.cl
+%%DATADIR%%/OpenCL/m00130_a0.cl
+%%DATADIR%%/OpenCL/m00130_a1.cl
+%%DATADIR%%/OpenCL/m00130_a3.cl
+%%DATADIR%%/OpenCL/m00140_a0.cl
+%%DATADIR%%/OpenCL/m00140_a1.cl
+%%DATADIR%%/OpenCL/m00140_a3.cl
+%%DATADIR%%/OpenCL/m00150_a0.cl
+%%DATADIR%%/OpenCL/m00150_a1.cl
+%%DATADIR%%/OpenCL/m00150_a3.cl
+%%DATADIR%%/OpenCL/m00160_a0.cl
+%%DATADIR%%/OpenCL/m00160_a1.cl
+%%DATADIR%%/OpenCL/m00160_a3.cl
+%%DATADIR%%/OpenCL/m00200_a0.cl
+%%DATADIR%%/OpenCL/m00200_a1.cl
+%%DATADIR%%/OpenCL/m00200_a3.cl
+%%DATADIR%%/OpenCL/m00300_a0.cl
+%%DATADIR%%/OpenCL/m00300_a1.cl
+%%DATADIR%%/OpenCL/m00300_a3.cl
+%%DATADIR%%/OpenCL/m00400.cl
+%%DATADIR%%/OpenCL/m00500.cl
+%%DATADIR%%/OpenCL/m00900_a0.cl
+%%DATADIR%%/OpenCL/m00900_a1.cl
+%%DATADIR%%/OpenCL/m00900_a3.cl
+%%DATADIR%%/OpenCL/m01000_a0.cl
+%%DATADIR%%/OpenCL/m01000_a1.cl
+%%DATADIR%%/OpenCL/m01000_a3.cl
+%%DATADIR%%/OpenCL/m01100_a0.cl
+%%DATADIR%%/OpenCL/m01100_a1.cl
+%%DATADIR%%/OpenCL/m01100_a3.cl
+%%DATADIR%%/OpenCL/m01400_a0.cl
+%%DATADIR%%/OpenCL/m01400_a1.cl
+%%DATADIR%%/OpenCL/m01400_a3.cl
+%%DATADIR%%/OpenCL/m01410_a0.cl
+%%DATADIR%%/OpenCL/m01410_a1.cl
+%%DATADIR%%/OpenCL/m01410_a3.cl
+%%DATADIR%%/OpenCL/m01420_a0.cl
+%%DATADIR%%/OpenCL/m01420_a1.cl
+%%DATADIR%%/OpenCL/m01420_a3.cl
+%%DATADIR%%/OpenCL/m01430_a0.cl
+%%DATADIR%%/OpenCL/m01430_a1.cl
+%%DATADIR%%/OpenCL/m01430_a3.cl
+%%DATADIR%%/OpenCL/m01440_a0.cl
+%%DATADIR%%/OpenCL/m01440_a1.cl
+%%DATADIR%%/OpenCL/m01440_a3.cl
+%%DATADIR%%/OpenCL/m01450_a0.cl
+%%DATADIR%%/OpenCL/m01450_a1.cl
+%%DATADIR%%/OpenCL/m01450_a3.cl
+%%DATADIR%%/OpenCL/m01460_a0.cl
+%%DATADIR%%/OpenCL/m01460_a1.cl
+%%DATADIR%%/OpenCL/m01460_a3.cl
+%%DATADIR%%/OpenCL/m01500_a0.cl
+%%DATADIR%%/OpenCL/m01500_a1.cl
+%%DATADIR%%/OpenCL/m01500_a3.cl
+%%DATADIR%%/OpenCL/m01600.cl
+%%DATADIR%%/OpenCL/m01700_a0.cl
+%%DATADIR%%/OpenCL/m01700_a1.cl
+%%DATADIR%%/OpenCL/m01700_a3.cl
+%%DATADIR%%/OpenCL/m01710_a0.cl
+%%DATADIR%%/OpenCL/m01710_a1.cl
+%%DATADIR%%/OpenCL/m01710_a3.cl
+%%DATADIR%%/OpenCL/m01720_a0.cl
+%%DATADIR%%/OpenCL/m01720_a1.cl
+%%DATADIR%%/OpenCL/m01720_a3.cl
+%%DATADIR%%/OpenCL/m01730_a0.cl
+%%DATADIR%%/OpenCL/m01730_a1.cl
+%%DATADIR%%/OpenCL/m01730_a3.cl
+%%DATADIR%%/OpenCL/m01740_a0.cl
+%%DATADIR%%/OpenCL/m01740_a1.cl
+%%DATADIR%%/OpenCL/m01740_a3.cl
+%%DATADIR%%/OpenCL/m01750_a0.cl
+%%DATADIR%%/OpenCL/m01750_a1.cl
+%%DATADIR%%/OpenCL/m01750_a3.cl
+%%DATADIR%%/OpenCL/m01760_a0.cl
+%%DATADIR%%/OpenCL/m01760_a1.cl
+%%DATADIR%%/OpenCL/m01760_a3.cl
+%%DATADIR%%/OpenCL/m01800.cl
+%%DATADIR%%/OpenCL/m02000_a0.cl
+%%DATADIR%%/OpenCL/m02000_a1.cl
+%%DATADIR%%/OpenCL/m02000_a3.cl
+%%DATADIR%%/OpenCL/m02100.cl
+%%DATADIR%%/OpenCL/m02400_a0.cl
+%%DATADIR%%/OpenCL/m02400_a1.cl
+%%DATADIR%%/OpenCL/m02400_a3.cl
+%%DATADIR%%/OpenCL/m02410_a0.cl
+%%DATADIR%%/OpenCL/m02410_a1.cl
+%%DATADIR%%/OpenCL/m02410_a3.cl
+%%DATADIR%%/OpenCL/m02500.cl
+%%DATADIR%%/OpenCL/m02610_a0.cl
+%%DATADIR%%/OpenCL/m02610_a1.cl
+%%DATADIR%%/OpenCL/m02610_a3.cl
+%%DATADIR%%/OpenCL/m02710_a0.cl
+%%DATADIR%%/OpenCL/m02710_a1.cl
+%%DATADIR%%/OpenCL/m02710_a3.cl
+%%DATADIR%%/OpenCL/m02810_a0.cl
+%%DATADIR%%/OpenCL/m02810_a1.cl
+%%DATADIR%%/OpenCL/m02810_a3.cl
+%%DATADIR%%/OpenCL/m03000_a0.cl
+%%DATADIR%%/OpenCL/m03000_a1.cl
+%%DATADIR%%/OpenCL/m03000_a3.cl
+%%DATADIR%%/OpenCL/m03100_a0.cl
+%%DATADIR%%/OpenCL/m03100_a1.cl
+%%DATADIR%%/OpenCL/m03100_a3.cl
+%%DATADIR%%/OpenCL/m03200.cl
+%%DATADIR%%/OpenCL/m03710_a0.cl
+%%DATADIR%%/OpenCL/m03710_a1.cl
+%%DATADIR%%/OpenCL/m03710_a3.cl
+%%DATADIR%%/OpenCL/m03800_a0.cl
+%%DATADIR%%/OpenCL/m03800_a1.cl
+%%DATADIR%%/OpenCL/m03800_a3.cl
+%%DATADIR%%/OpenCL/m04310_a0.cl
+%%DATADIR%%/OpenCL/m04310_a1.cl
+%%DATADIR%%/OpenCL/m04310_a3.cl
+%%DATADIR%%/OpenCL/m04400_a0.cl
+%%DATADIR%%/OpenCL/m04400_a1.cl
+%%DATADIR%%/OpenCL/m04400_a3.cl
+%%DATADIR%%/OpenCL/m04500_a0.cl
+%%DATADIR%%/OpenCL/m04500_a1.cl
+%%DATADIR%%/OpenCL/m04500_a3.cl
+%%DATADIR%%/OpenCL/m04700_a0.cl
+%%DATADIR%%/OpenCL/m04700_a1.cl
+%%DATADIR%%/OpenCL/m04700_a3.cl
+%%DATADIR%%/OpenCL/m04800_a0.cl
+%%DATADIR%%/OpenCL/m04800_a1.cl
+%%DATADIR%%/OpenCL/m04800_a3.cl
+%%DATADIR%%/OpenCL/m04900_a0.cl
+%%DATADIR%%/OpenCL/m04900_a1.cl
+%%DATADIR%%/OpenCL/m04900_a3.cl
+%%DATADIR%%/OpenCL/m05000_a0.cl
+%%DATADIR%%/OpenCL/m05000_a1.cl
+%%DATADIR%%/OpenCL/m05000_a3.cl
+%%DATADIR%%/OpenCL/m05100_a0.cl
+%%DATADIR%%/OpenCL/m05100_a1.cl
+%%DATADIR%%/OpenCL/m05100_a3.cl
+%%DATADIR%%/OpenCL/m05200.cl
+%%DATADIR%%/OpenCL/m05300_a0.cl
+%%DATADIR%%/OpenCL/m05300_a1.cl
+%%DATADIR%%/OpenCL/m05300_a3.cl
+%%DATADIR%%/OpenCL/m05400_a0.cl
+%%DATADIR%%/OpenCL/m05400_a1.cl
+%%DATADIR%%/OpenCL/m05400_a3.cl
+%%DATADIR%%/OpenCL/m05500_a0.cl
+%%DATADIR%%/OpenCL/m05500_a1.cl
+%%DATADIR%%/OpenCL/m05500_a3.cl
+%%DATADIR%%/OpenCL/m05600_a0.cl
+%%DATADIR%%/OpenCL/m05600_a1.cl
+%%DATADIR%%/OpenCL/m05600_a3.cl
+%%DATADIR%%/OpenCL/m05800.cl
+%%DATADIR%%/OpenCL/m06000_a0.cl
+%%DATADIR%%/OpenCL/m06000_a1.cl
+%%DATADIR%%/OpenCL/m06000_a3.cl
+%%DATADIR%%/OpenCL/m06100_a0.cl
+%%DATADIR%%/OpenCL/m06100_a1.cl
+%%DATADIR%%/OpenCL/m06100_a3.cl
+%%DATADIR%%/OpenCL/m06211.cl
+%%DATADIR%%/OpenCL/m06212.cl
+%%DATADIR%%/OpenCL/m06213.cl
+%%DATADIR%%/OpenCL/m06221.cl
+%%DATADIR%%/OpenCL/m06222.cl
+%%DATADIR%%/OpenCL/m06223.cl
+%%DATADIR%%/OpenCL/m06231.cl
+%%DATADIR%%/OpenCL/m06232.cl
+%%DATADIR%%/OpenCL/m06233.cl
+%%DATADIR%%/OpenCL/m06300.cl
+%%DATADIR%%/OpenCL/m06400.cl
+%%DATADIR%%/OpenCL/m06500.cl
+%%DATADIR%%/OpenCL/m06600.cl
+%%DATADIR%%/OpenCL/m06700.cl
+%%DATADIR%%/OpenCL/m06800.cl
+%%DATADIR%%/OpenCL/m06900_a0.cl
+%%DATADIR%%/OpenCL/m06900_a1.cl
+%%DATADIR%%/OpenCL/m06900_a3.cl
+%%DATADIR%%/OpenCL/m07100.cl
+%%DATADIR%%/OpenCL/m07300_a0.cl
+%%DATADIR%%/OpenCL/m07300_a1.cl
+%%DATADIR%%/OpenCL/m07300_a3.cl
+%%DATADIR%%/OpenCL/m07400.cl
+%%DATADIR%%/OpenCL/m07500_a0.cl
+%%DATADIR%%/OpenCL/m07500_a1.cl
+%%DATADIR%%/OpenCL/m07500_a3.cl
+%%DATADIR%%/OpenCL/m07600_a0.cl
+%%DATADIR%%/OpenCL/m07600_a1.cl
+%%DATADIR%%/OpenCL/m07600_a3.cl
+%%DATADIR%%/OpenCL/m07700_a0.cl
+%%DATADIR%%/OpenCL/m07700_a1.cl
+%%DATADIR%%/OpenCL/m07700_a3.cl
+%%DATADIR%%/OpenCL/m07800_a0.cl
+%%DATADIR%%/OpenCL/m07800_a1.cl
+%%DATADIR%%/OpenCL/m07800_a3.cl
+%%DATADIR%%/OpenCL/m07900.cl
+%%DATADIR%%/OpenCL/m08000_a0.cl
+%%DATADIR%%/OpenCL/m08000_a1.cl
+%%DATADIR%%/OpenCL/m08000_a3.cl
+%%DATADIR%%/OpenCL/m08100_a0.cl
+%%DATADIR%%/OpenCL/m08100_a1.cl
+%%DATADIR%%/OpenCL/m08100_a3.cl
+%%DATADIR%%/OpenCL/m08200.cl
+%%DATADIR%%/OpenCL/m08300_a0.cl
+%%DATADIR%%/OpenCL/m08300_a1.cl
+%%DATADIR%%/OpenCL/m08300_a3.cl
+%%DATADIR%%/OpenCL/m08400_a0.cl
+%%DATADIR%%/OpenCL/m08400_a1.cl
+%%DATADIR%%/OpenCL/m08400_a3.cl
+%%DATADIR%%/OpenCL/m08500_a0.cl
+%%DATADIR%%/OpenCL/m08500_a1.cl
+%%DATADIR%%/OpenCL/m08500_a3.cl
+%%DATADIR%%/OpenCL/m08600_a0.cl
+%%DATADIR%%/OpenCL/m08600_a1.cl
+%%DATADIR%%/OpenCL/m08600_a3.cl
+%%DATADIR%%/OpenCL/m08700_a0.cl
+%%DATADIR%%/OpenCL/m08700_a1.cl
+%%DATADIR%%/OpenCL/m08700_a3.cl
+%%DATADIR%%/OpenCL/m08800.cl
+%%DATADIR%%/OpenCL/m08900.cl
+%%DATADIR%%/OpenCL/m09000.cl
+%%DATADIR%%/OpenCL/m09100.cl
+%%DATADIR%%/OpenCL/m09400.cl
+%%DATADIR%%/OpenCL/m09500.cl
+%%DATADIR%%/OpenCL/m09600.cl
+%%DATADIR%%/OpenCL/m09700_a0.cl
+%%DATADIR%%/OpenCL/m09700_a1.cl
+%%DATADIR%%/OpenCL/m09700_a3.cl
+%%DATADIR%%/OpenCL/m09710_a0.cl
+%%DATADIR%%/OpenCL/m09710_a1.cl
+%%DATADIR%%/OpenCL/m09710_a3.cl
+%%DATADIR%%/OpenCL/m09720_a0.cl
+%%DATADIR%%/OpenCL/m09720_a1.cl
+%%DATADIR%%/OpenCL/m09720_a3.cl
+%%DATADIR%%/OpenCL/m09800_a0.cl
+%%DATADIR%%/OpenCL/m09800_a1.cl
+%%DATADIR%%/OpenCL/m09800_a3.cl
+%%DATADIR%%/OpenCL/m09810_a0.cl
+%%DATADIR%%/OpenCL/m09810_a1.cl
+%%DATADIR%%/OpenCL/m09810_a3.cl
+%%DATADIR%%/OpenCL/m09820_a0.cl
+%%DATADIR%%/OpenCL/m09820_a1.cl
+%%DATADIR%%/OpenCL/m09820_a3.cl
+%%DATADIR%%/OpenCL/m09900_a0.cl
+%%DATADIR%%/OpenCL/m09900_a1.cl
+%%DATADIR%%/OpenCL/m09900_a3.cl
+%%DATADIR%%/OpenCL/m10100_a0.cl
+%%DATADIR%%/OpenCL/m10100_a1.cl
+%%DATADIR%%/OpenCL/m10100_a3.cl
+%%DATADIR%%/OpenCL/m10300.cl
+%%DATADIR%%/OpenCL/m10400_a0.cl
+%%DATADIR%%/OpenCL/m10400_a1.cl
+%%DATADIR%%/OpenCL/m10400_a3.cl
+%%DATADIR%%/OpenCL/m10410_a0.cl
+%%DATADIR%%/OpenCL/m10410_a1.cl
+%%DATADIR%%/OpenCL/m10410_a3.cl
+%%DATADIR%%/OpenCL/m10420_a0.cl
+%%DATADIR%%/OpenCL/m10420_a1.cl
+%%DATADIR%%/OpenCL/m10420_a3.cl
+%%DATADIR%%/OpenCL/m10500.cl
+%%DATADIR%%/OpenCL/m10700.cl
+%%DATADIR%%/OpenCL/m10800_a0.cl
+%%DATADIR%%/OpenCL/m10800_a1.cl
+%%DATADIR%%/OpenCL/m10800_a3.cl
+%%DATADIR%%/OpenCL/m10900.cl
+%%DATADIR%%/OpenCL/m11000_a0.cl
+%%DATADIR%%/OpenCL/m11000_a1.cl
+%%DATADIR%%/OpenCL/m11000_a3.cl
+%%DATADIR%%/OpenCL/m11100_a0.cl
+%%DATADIR%%/OpenCL/m11100_a1.cl
+%%DATADIR%%/OpenCL/m11100_a3.cl
+%%DATADIR%%/OpenCL/m11200_a0.cl
+%%DATADIR%%/OpenCL/m11200_a1.cl
+%%DATADIR%%/OpenCL/m11200_a3.cl
+%%DATADIR%%/OpenCL/m11300.cl
+%%DATADIR%%/OpenCL/m11400_a0.cl
+%%DATADIR%%/OpenCL/m11400_a1.cl
+%%DATADIR%%/OpenCL/m11400_a3.cl
+%%DATADIR%%/OpenCL/m11500_a0.cl
+%%DATADIR%%/OpenCL/m11500_a1.cl
+%%DATADIR%%/OpenCL/m11500_a3.cl
+%%DATADIR%%/OpenCL/m11600.cl
+%%DATADIR%%/OpenCL/m11700_a0.cl
+%%DATADIR%%/OpenCL/m11700_a1.cl
+%%DATADIR%%/OpenCL/m11700_a3.cl
+%%DATADIR%%/OpenCL/m11800_a0.cl
+%%DATADIR%%/OpenCL/m11800_a1.cl
+%%DATADIR%%/OpenCL/m11800_a3.cl
+%%DATADIR%%/OpenCL/m11900.cl
+%%DATADIR%%/OpenCL/m12000.cl
+%%DATADIR%%/OpenCL/m12200.cl
+%%DATADIR%%/OpenCL/m12300.cl
+%%DATADIR%%/OpenCL/m12400.cl
+%%DATADIR%%/OpenCL/m12500.cl
+%%DATADIR%%/OpenCL/m12600_a0.cl
+%%DATADIR%%/OpenCL/m12600_a1.cl
+%%DATADIR%%/OpenCL/m12600_a3.cl
+%%DATADIR%%/OpenCL/m12700.cl
+%%DATADIR%%/OpenCL/m12800.cl
+%%DATADIR%%/OpenCL/m12900.cl
+%%DATADIR%%/OpenCL/m13000.cl
+%%DATADIR%%/OpenCL/m13100_a0.cl
+%%DATADIR%%/OpenCL/m13100_a1.cl
+%%DATADIR%%/OpenCL/m13100_a3.cl
+%%DATADIR%%/OpenCL/m13200.cl
+%%DATADIR%%/OpenCL/m13300_a0.cl
+%%DATADIR%%/OpenCL/m13300_a1.cl
+%%DATADIR%%/OpenCL/m13300_a3.cl
+%%DATADIR%%/OpenCL/m13400.cl
+%%DATADIR%%/OpenCL/m13500_a0.cl
+%%DATADIR%%/OpenCL/m13500_a1.cl
+%%DATADIR%%/OpenCL/m13500_a3.cl
+%%DATADIR%%/OpenCL/m13600.cl
+%%DATADIR%%/OpenCL/m13751.cl
+%%DATADIR%%/OpenCL/m13752.cl
+%%DATADIR%%/OpenCL/m13753.cl
+%%DATADIR%%/OpenCL/m13800_a0.cl
+%%DATADIR%%/OpenCL/m13800_a1.cl
+%%DATADIR%%/OpenCL/m13800_a3.cl
+%%DATADIR%%/OpenCL/markov_be.cl
+%%DATADIR%%/OpenCL/markov_le.cl
%%DATADIR%%/charsets/combined/Bulgarian.hcchr
%%DATADIR%%/charsets/combined/Castilian.hcchr
%%DATADIR%%/charsets/combined/Catalan.hcchr
@@ -140,10 +466,20 @@ bin/hashcat-cliXOP.bin
%%DATADIR%%/charsets/standard/Spanish/es_ISO-8859-1.hcchr
%%DATADIR%%/charsets/standard/Spanish/es_ISO-8859-15.hcchr
%%DATADIR%%/charsets/standard/Spanish/es_cp1252.hcchr
+%%DATADIR%%/hashcat.hcstat
+%%DATADIR%%/hashcat.hctune
+%%DATADIR%%/masks/8char-1l-1u-1d-1s-compliant.hcmask
+%%DATADIR%%/masks/8char-1l-1u-1d-1s-noncompliant.hcmask
+%%DATADIR%%/masks/rockyou-1-60.hcmask
+%%DATADIR%%/masks/rockyou-2-1800.hcmask
+%%DATADIR%%/masks/rockyou-3-3600.hcmask
+%%DATADIR%%/masks/rockyou-4-43200.hcmask
+%%DATADIR%%/masks/rockyou-5-86400.hcmask
+%%DATADIR%%/masks/rockyou-6-864000.hcmask
+%%DATADIR%%/masks/rockyou-7-2592000.hcmask
%%DATADIR%%/rules/Incisive-leetspeak.rule
%%DATADIR%%/rules/InsidePro-HashManager.rule
%%DATADIR%%/rules/InsidePro-PasswordsPro.rule
-%%DATADIR%%/rules/Ninja-leetspeak.rule
%%DATADIR%%/rules/T0XlC-insert_00-99_1950-2050_toprules_0_F.rule
%%DATADIR%%/rules/T0XlC-insert_space_and_special_0_F.rule
%%DATADIR%%/rules/T0XlC-insert_top_100_passwords_1_G.rule
@@ -154,6 +490,41 @@ bin/hashcat-cliXOP.bin
%%DATADIR%%/rules/d3ad0ne.rule
%%DATADIR%%/rules/dive.rule
%%DATADIR%%/rules/generated.rule
+%%DATADIR%%/rules/generated2.rule
+%%DATADIR%%/rules/hybrid/append_d.rule
+%%DATADIR%%/rules/hybrid/append_ds.rule
+%%DATADIR%%/rules/hybrid/append_du.rule
+%%DATADIR%%/rules/hybrid/append_dus.rule
+%%DATADIR%%/rules/hybrid/append_hl.rule
+%%DATADIR%%/rules/hybrid/append_hu.rule
+%%DATADIR%%/rules/hybrid/append_l.rule
+%%DATADIR%%/rules/hybrid/append_ld.rule
+%%DATADIR%%/rules/hybrid/append_lds.rule
+%%DATADIR%%/rules/hybrid/append_ldu.rule
+%%DATADIR%%/rules/hybrid/append_ldus.rule
+%%DATADIR%%/rules/hybrid/append_ls.rule
+%%DATADIR%%/rules/hybrid/append_lu.rule
+%%DATADIR%%/rules/hybrid/append_lus.rule
+%%DATADIR%%/rules/hybrid/append_s.rule
+%%DATADIR%%/rules/hybrid/append_u.rule
+%%DATADIR%%/rules/hybrid/append_us.rule
+%%DATADIR%%/rules/hybrid/prepend_d.rule
+%%DATADIR%%/rules/hybrid/prepend_ds.rule
+%%DATADIR%%/rules/hybrid/prepend_du.rule
+%%DATADIR%%/rules/hybrid/prepend_dus.rule
+%%DATADIR%%/rules/hybrid/prepend_hl.rule
+%%DATADIR%%/rules/hybrid/prepend_hu.rule
+%%DATADIR%%/rules/hybrid/prepend_l.rule
+%%DATADIR%%/rules/hybrid/prepend_ld.rule
+%%DATADIR%%/rules/hybrid/prepend_lds.rule
+%%DATADIR%%/rules/hybrid/prepend_ldu.rule
+%%DATADIR%%/rules/hybrid/prepend_ldus.rule
+%%DATADIR%%/rules/hybrid/prepend_ls.rule
+%%DATADIR%%/rules/hybrid/prepend_lu.rule
+%%DATADIR%%/rules/hybrid/prepend_lus.rule
+%%DATADIR%%/rules/hybrid/prepend_s.rule
+%%DATADIR%%/rules/hybrid/prepend_u.rule
+%%DATADIR%%/rules/hybrid/prepend_us.rule
%%DATADIR%%/rules/leetspeak.rule
%%DATADIR%%/rules/oscommerce.rule
%%DATADIR%%/rules/rockyou-30000.rule
@@ -163,11 +534,4 @@ bin/hashcat-cliXOP.bin
%%DATADIR%%/rules/toggles3.rule
%%DATADIR%%/rules/toggles4.rule
%%DATADIR%%/rules/toggles5.rule
-%%DATADIR%%/salts/brute-oscommerce.salt
-%%DATADIR%%/salts/brute-vbulletin.salt
-%%DATADIR%%/tables/digits.table
-%%DATADIR%%/tables/keyboard.en_ar1.utf8.table
-%%DATADIR%%/tables/keyboard.en_ar2.utf8.table
-%%DATADIR%%/tables/leet.table
-%%DATADIR%%/tables/toggle_case.table
-%%DATADIR%%/tables/toggle_case_and_leet.table
+%%DATADIR%%/rules/unix-ninja-leetspeak.rule