aboutsummaryrefslogtreecommitdiffstats
path: root/security/hlfl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/hlfl/Makefile')
-rw-r--r--security/hlfl/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/security/hlfl/Makefile b/security/hlfl/Makefile
index f813be379655..026f775fb62d 100644
--- a/security/hlfl/Makefile
+++ b/security/hlfl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= hlfl
PORTVERSION= 0.60.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ftp://ftp.hlfl.org/pub/hlfl/
@@ -11,18 +12,16 @@ COMMENT= High Level Firewall Language
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --datadir=${LOCALBASE}/share/doc
-DOC_FILES= services.hlfl sample_1.hlfl sample_2.hlfl test.hlfl syntax.txt
-MAN1= hlfl.1
+PORTDOCS= services.hlfl sample_1.hlfl sample_2.hlfl test.hlfl syntax.txt
+PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
+PORT_OPTIONS= DOCS
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/hlfl ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/doc/${MAN1} ${PREFIX}/man/man1
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/hlfl
-.for i in ${DOC_FILES}
- ${INSTALL_DATA} ${WRKSRC}/doc/${i} ${PREFIX}/share/doc/hlfl
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/hlfl ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/doc/${MAN1} ${STAGEDIR}${PREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>