aboutsummaryrefslogtreecommitdiffstats
path: root/security/hpn-ssh/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/hpn-ssh/Makefile')
-rw-r--r--security/hpn-ssh/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/security/hpn-ssh/Makefile b/security/hpn-ssh/Makefile
index c0e6f1fca76d..ca1133761e69 100644
--- a/security/hpn-ssh/Makefile
+++ b/security/hpn-ssh/Makefile
@@ -83,10 +83,10 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 430000
-OPENSSLBASE= /usr/local
+.if ${OSVERSION} < 430000 || exists(${LOCALBASE}/lib/libcrypto.so.3)
+OPENSSLBASE= ${LOCALBASE}
OPENSSLDIR= ${OPENSSLBASE}/openssl
-LIB_DEPENDS+= crypto.2:${PORTSDIR}/security/openssl
+LIB_DEPENDS+= crypto.3:${PORTSDIR}/security/openssl
OPENSSLLIB= ${OPENSSLBASE}/lib
OPENSSLINC= ${OPENSSLBASE}/include
MAKE_ENV+= OPENSSLLIB=${OPENSSLLIB} OPENSSLINC=${OPENSSLINC} \