aboutsummaryrefslogtreecommitdiffstats
path: root/security/mhash/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/mhash/Makefile')
-rw-r--r--security/mhash/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/security/mhash/Makefile b/security/mhash/Makefile
index 722f0cfeec6d..b10315d79d67 100644
--- a/security/mhash/Makefile
+++ b/security/mhash/Makefile
@@ -3,18 +3,20 @@
PORTNAME= mhash
PORTVERSION= 0.9.9.9
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Easy-to-use library for strong hashes such as MD5 and SHA1
+LICENSE= LGPL20 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USES= tar:bzip2 libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-static --with-gnu-ld
-INSTALL_TARGET= install-strip
PORTDOCS= example.c skid2-authentication
@@ -22,6 +24,7 @@ test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libmhash.so
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/doc/,} ${STAGEDIR}${DOCSDIR}