aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl
diff options
context:
space:
mode:
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile2
-rw-r--r--security/openssl/files/patch-eng_cryptodev.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 580d2caf7674..0a788dd403fa 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openssl
PORTVERSION= 0.9.8k
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/%SUBDIR%/ \
ftp://ftp.openssl.org/%SUBDIR%/ \
diff --git a/security/openssl/files/patch-eng_cryptodev.c b/security/openssl/files/patch-eng_cryptodev.c
index 89339f988bf4..8b8942c098ff 100644
--- a/security/openssl/files/patch-eng_cryptodev.c
+++ b/security/openssl/files/patch-eng_cryptodev.c
@@ -58,7 +58,7 @@
+ if (retfd == -1)
+ retfd = fd;
+ else
-+ close(fd);
++/* close(fd); fix for PR=138881 */
/* close on exec */
if (fcntl(retfd, F_SETFD, 1) == -1) {