aboutsummaryrefslogtreecommitdiffstats
path: root/security/pam_af
diff options
context:
space:
mode:
Diffstat (limited to 'security/pam_af')
-rw-r--r--security/pam_af/Makefile1
-rw-r--r--security/pam_af/files/patch-common_pam_af.h11
-rw-r--r--security/pam_af/files/patch-common_subr.c11
-rw-r--r--security/pam_af/files/patch-pam_af.c11
4 files changed, 34 insertions, 0 deletions
diff --git a/security/pam_af/Makefile b/security/pam_af/Makefile
index 4cb63df6234c..9128ab6b1cbe 100644
--- a/security/pam_af/Makefile
+++ b/security/pam_af/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pam_af
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://mbsd.msk.ru/dist/
diff --git a/security/pam_af/files/patch-common_pam_af.h b/security/pam_af/files/patch-common_pam_af.h
new file mode 100644
index 000000000000..3d47c278b685
--- /dev/null
+++ b/security/pam_af/files/patch-common_pam_af.h
@@ -0,0 +1,11 @@
+--- common/pam_af.h.orig 2008-08-02 20:32:55.000000000 +0400
++++ common/pam_af.h 2008-08-02 20:33:08.000000000 +0400
+@@ -37,7 +37,7 @@
+ #define CFGDB "/etc/pam_af.conf"
+ #define CFGDB_PERM (S_IRUSR | S_IWUSR)
+
+-#ifdef _OPENPAM
++#ifdef OPENPAM
+ # define PAM_AF_LOG(...) \
+ PAM_LOG(__VA_ARGS__)
+ # define PAM_AF_LOGERR(...) \
diff --git a/security/pam_af/files/patch-common_subr.c b/security/pam_af/files/patch-common_subr.c
new file mode 100644
index 000000000000..982b146c489a
--- /dev/null
+++ b/security/pam_af/files/patch-common_subr.c
@@ -0,0 +1,11 @@
+--- common/subr.c.orig 2008-08-02 20:33:51.000000000 +0400
++++ common/subr.c 2008-08-02 20:34:25.000000000 +0400
+@@ -66,7 +66,7 @@
+ # define LOGERR(...) warnx(__VA_ARGS__)
+ #else /* !PAM_AF_DEFS */
+ # include <security/pam_appl.h>
+-# ifdef _OPENPAM
++# ifdef OPENPAM
+ # include <security/pam_mod_misc.h>
+ # include <security/openpam.h>
+ # endif
diff --git a/security/pam_af/files/patch-pam_af.c b/security/pam_af/files/patch-pam_af.c
new file mode 100644
index 000000000000..8c7f3c044edc
--- /dev/null
+++ b/security/pam_af/files/patch-pam_af.c
@@ -0,0 +1,11 @@
+--- pam_af.c.orig 2008-08-02 20:34:30.000000000 +0400
++++ pam_af.c 2008-08-02 20:34:36.000000000 +0400
+@@ -53,7 +53,7 @@
+
+ #include <security/pam_appl.h>
+ #include <security/pam_modules.h>
+-#ifdef _OPENPAM
++#ifdef OPENPAM
+ # include <security/openpam.h>
+ # include <security/pam_mod_misc.h>
+ #endif