aboutsummaryrefslogtreecommitdiffstats
path: root/security/pinentry
diff options
context:
space:
mode:
Diffstat (limited to 'security/pinentry')
-rw-r--r--security/pinentry/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/security/pinentry/Makefile b/security/pinentry/Makefile
index 19039742f37d..8fb8360bb835 100644
--- a/security/pinentry/Makefile
+++ b/security/pinentry/Makefile
@@ -39,6 +39,7 @@ PLIST_SUB+= WITH_QT="@comment "
.if defined(PINENTRY_GTK)
USE_GNOME+= gtk12
+CONFIGURE_ARGS+=--with-extra-libs=${LOCALBASE}/lib --with-extra-includes=${LOCALBASE}/include
PLIST_SUB+= WITH_GTK=""
.else
CONFIGURE_ARGS+=--disable-pinentry-gtk
@@ -46,6 +47,7 @@ PLIST_SUB+= WITH_GTK="@comment "
.endif
.if defined(PINENTRY_CURSES)
+CONFIGURE_ARGS+=--with-extra-libs=${LOCALBASE}/lib --with-extra-includes=${LOCALBASE}/include
PLIST_SUB+= WITH_CURSES=""
.else
CONFIGURE_ARGS+=--disable-pinentry-curses