aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-PF/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-PF/Makefile')
-rw-r--r--security/py-PF/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/security/py-PF/Makefile b/security/py-PF/Makefile
index a04042364e48..d3434b5392b6 100644
--- a/security/py-PF/Makefile
+++ b/security/py-PF/Makefile
@@ -6,21 +6,28 @@
#
PORTNAME= PF
-PORTVERSION= 0.0.4
+PORTVERSION= 0.0.5
CATEGORIES= security python
MASTER_SITES= SF/py-${PORTNAME:L}/py-${PORTNAME:L}/${DISTNAME}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= ${PYTHON_PKGNAMEPREFIX:C/[0-9]+//}${PORTNAME}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
MAINTAINER= sbrabez@gmail.com
COMMENT= A pure-Python module for managing OpenBSD Packet Filter
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
USE_PYTHON= 2.5+
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= ${PYTHON_PKGNAMEPREFIX:C/[0-9]+//}_${PORTNAME}
SUB_FILES= pkg-message
+post-patch:
+ @${REINPLACE_CMD} -e 's#"0.0.4"#"0.0.5"#g' ${WRKSRC}/setup.py
+
post-install:
.if !defined(BATCH)
@${CAT} ${PKGMESSAGE}