aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-fail2ban/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-fail2ban/Makefile')
-rw-r--r--security/py-fail2ban/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/security/py-fail2ban/Makefile b/security/py-fail2ban/Makefile
index 221a5b99b8af..aec19797620b 100644
--- a/security/py-fail2ban/Makefile
+++ b/security/py-fail2ban/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= fail2ban
-PORTVERSION= 0.10.1
-PORTREVISION= 1
+PORTVERSION= 0.10.2
CATEGORIES= security python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -48,6 +47,11 @@ MAN_FILES= ${WRKSRC}/man/fail2ban-client.1 \
FAIL2BAN_DBDIR= /var/db/${PORTNAME}
+PY2TO3_CMD= ${LOCALBASE}/bin/2to3-${PYTHON_VER}
+PY2TO3_ARG= --no-diffs --write --nobackups --fix=all
+
+.include <bsd.port.pre.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's,/etc/fail2ban,${ETCDIR},g' ${FILES}
@${REINPLACE_CMD} -e 's,paths-debian.conf,paths-freebsd.conf,g' \
@@ -57,6 +61,10 @@ post-patch:
@${REINPLACE_CMD} -e 's,jail.conf(5),fail2ban-jail.conf(5),g' \
${MAN_FILES}
+. if ${PYTHON_MAJOR_VER} >= 3
+ (cd ${WRKSRC}/ && ${PY2TO3_CMD} ${PY2TO3_ARG} bin/* fail2ban)
+. endif
+
post-install:
@${MKDIR} ${STAGEDIR}${FAIL2BAN_DBDIR} ${STAGEDIR}/var/run/fail2ban
.for file in fail2ban-client fail2ban-regex fail2ban-server fail2ban
@@ -71,4 +79,4 @@ post-install-DOCS-on:
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>